Bug 734850 - beaker-watchdog run method doesn't handle exceptions
Summary: beaker-watchdog run method doesn't handle exceptions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: lab controller
Version: 0.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
: 692538 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 15:52 UTC by Bill Peck
Modified: 2019-05-22 13:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-20 06:19:02 UTC


Attachments (Terms of Use)

Description Bill Peck 2011-08-31 15:52:50 UTC
Description of problem:
Currently if we have a problem communicating to the server and get an xmlrpclib.Fault then the whole beaker-watchdog process will die.

Version-Release number of selected component (if applicable):
0.7.00

We should handle the exception in the run loop so we not only prevent ourselves from exiting but continue the run loop.

Comment 1 Bill Peck 2011-09-15 19:00:13 UTC
*** Bug 692538 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.