Bug 734882 - Katello not correctly parsing (some?) error messages returned from candlepin
Summary: Katello not correctly parsing (some?) error messages returned from candlepin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-31 18:22 UTC by Corey Welton
Modified: 2019-02-25 21:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
client: subscription-manager-0.96.8-1.git.0.125eb68.el6.x86_64 python-rhsm-0.96.10-1.git.1.de18258.el6.noarch server: katello-0.1.71-1.git.3.020bc22.fc14.noarch
Last Closed: 2012-08-22 17:54:56 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-08-31 18:22:19 UTC
Description of problem:
If a user uses subscription-manager to try and subscribe to a nonexistent pool in katello, the error returned appears to be raw json, versus the properly formatted error message itself.  Modifying /etc/rhsm/rhsm.conf to point to the candlepin server itself results in a a correct error message.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Assure there are (valid) subscription pools in Katello.
2. Register a system to katello
3. Attempt to subscribe to a pool using an /invalid/ pool id... i.e., 'subscription-manager subscribe --pool=ff808081321b487e01321b5a94640010'
4. View results
  
Actual results:
{"displayMessage":"Subscription pool ff808081321b487e01321b5a94640010 does not exist."}

Expected results:
Subscription pool ff808081321b487e01321b5a94640010 does not exist.


Additional info:
To reiterate, if user modifies rhsm.conf to point to the appropriate respective endpoint and port for the underlying candlepin, the proper error message appears.

Comment 1 Ivan Necas 2011-09-19 14:56:47 UTC
Fixed in commit 879bc605a45e5d7e8a1a7f4a8fc263a78ef474ad

Comment 2 Jeff Weiss 2011-09-26 16:40:32 UTC
Verified, katello-0.1.84-1.git.26.51fa1e1.fc14.noarch

Comment 5 Mike McCune 2013-08-16 17:55:29 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.