Bug 734896 - multi-entitlement subscribe attempts are NOT getting rejected for non multi-entitlement pools
Summary: multi-entitlement subscribe attempts are NOT getting rejected for non multi-e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-31 19:20 UTC by John Sefler
Modified: 2011-12-06 17:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC
Red Hat Bugzilla 729070 None None None Never

Description John Sefler 2011-08-31 19:20:10 UTC
Description of problem:
In the stage environment, my attempts to subscribe with --quatity>1 against a pool whose Multi-Entitlement is No are not getting blocked.


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.7-1.el6.x86_64
I SUSPECT THIS IS A CANDLEPIN BUG, BUT I DON"T KNOW WHAT VERSION IS DEPLOYED IN STAGE.


How reproducible:


Steps to Reproduce:
[root@jsefler-stage-6server ~]# grep hostname /etc/rhsm/rhsm.conf
# Server hostname:
hostname=subscription.rhn.stage.redhat.com
proxy_hostname=


[root@jsefler-stage-6server ~]# subscription-manager register --user stage_test_12
Password: 
The system has been registered with id: 2a4c55fc-cb78-42f6-a31a-e8836d198075 
[root@jsefler-stage-6server ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	91                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	400                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual                  

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf420130991163ac0c56 --quantity=10
Successfully subscribed the system to Pool 8a99f981308acf420130991163ac0c56

^^^ I EXPECTED THAT RESULT TO BE BLOCKED WITH:
Multi-entitlement not supported for pool with id '8a99f981308acf420130991163ac0c56'.

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad7101d3a --quantity=10
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad7101d3a


^^^ I EXPECTED THAT RESULT TO BE BLOCKED WITH:
Multi-entitlement not supported for pool with id '8a99f981308acf4201308b9ad7101d3a'.

Comment 1 John Sefler 2011-08-31 19:23:36 UTC
Note: I can NOT reproduce this bug against my local onpremises candlepin deployed with TESTDATA=1.  This same test passes against my onpremises environment.

Comment 2 William Poteat 2011-09-09 15:10:28 UTC
Corrected here

https://bugzilla.redhat.com/show_bug.cgi?id=729070

In versions >= candlepin-0.4.11-1

Comment 4 Shwetha Kallesh 2011-09-14 06:49:59 UTC
Moving the bug to verified..

RPM used:

rpm -q subscription-manager
subscription-manager-0.96.9-1.git.10.adab5e3.el6.x86_64

Steps to reproduce the same:

subscription-manager subscribe --pool=ff8080813255d44a013255d53aca0719 --quantity=10
Multi-entitlement not supported for pool with id 'ff8080813255d44a013255d53aca0719'.

Comment 5 errata-xmlrpc 2011-12-06 17:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.