Bug 734908 - Attempting to rename a changeset results in raw JSON in the name field.
Summary: Attempting to rename a changeset results in raw JSON in the name field.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-31 20:07 UTC by Corey Welton
Modified: 2013-08-16 18:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:08 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-08-31 20:07:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add an environment to ACME_Corporation ("dev")
2. Create a changeset ("TestChangeset"). Promote changeset to 'dev'
3. Navigate to Dev environment and choose the changeset; attempt to rename it to 
4. View results  

Actual results:
{"name":"Test Changeset","timestamp":"1314821089"} in the name field.  The name does actually appear to get changed, however, if one re-navigates to the main view.

Expected results:
Don't show this JSON, show the proper user-friendly string.

Additional info:
Does not seem to occur for the description field, etc.

Comment 1 Eric Helms 2011-09-09 15:09:53 UTC
commit 9448eb84988a00728dab3660dbd2d1a9ad25ae6e

Should be fixed as of the above commit.

Comment 2 Corey Welton 2011-09-22 14:05:55 UTC
QA verified

Comment 5 Mike McCune 2013-08-16 18:17:50 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.