Bug 734967 - /sbin/loader received SIGSEGV when using kickstart file.
/sbin/loader received SIGSEGV when using kickstart file.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
AcceptedNTH
:
: 744341 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-08-31 20:11 EDT by Andrew Stiegmann
Modified: 2014-09-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-02 21:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files containing the screenshot and the ks file. (5.92 KB, application/zip)
2011-08-31 20:11 EDT, Andrew Stiegmann
no flags Details
The anaconda log file. (2.19 KB, text/x-log)
2011-09-06 14:08 EDT, Andrew Stiegmann
no flags Details
Screen shot of the SEGV in the loader (5.84 KB, image/png)
2011-09-13 16:16 EDT, Andrew Stiegmann
no flags Details
Loader core file. (12.40 MB, application/octet-stream)
2011-09-13 16:27 EDT, Andrew Stiegmann
no flags Details

  None (edit)
Description Andrew Stiegmann 2011-08-31 20:11:01 EDT
Created attachment 520925 [details]
Files containing the screenshot and the ks file.

Description of problem:
/sbin/loader is segfaulting when I attempt to use a kickstart file (attached) to install the system.  This is reproduced using the Easy Install feature of Workstation 8.0

How reproducible:
100%

Steps to Reproduce:
1. Create a new VM with fedora 16 a1 as the guest
2. Boot the VM
  
Actual results:
SIGSEGV

Expected results:
Automatic installation.

Additional info:
The kickstart file along with a screen shot of the back trace is attached to the bug.
Comment 1 Ales Kozumplik 2011-09-05 07:39:20 EDT
Hi Andrew,

I am unable to reproduce this. Please try switching to tty2 after the crash and scp /tmp/anaconda.log to another computer. Then please attach this file to the bug report.
Comment 2 Andrew Stiegmann 2011-09-05 15:55:41 EDT
Ales,
   Did you try using Workstation 8.0 (or perhaps Workstation 7.x)?  The Easy Install feature there creates a smaller ISO with the kernel, initrd, kickstart file and a couple of other files to avoid having to remaster the entire ISO.  I am wondering if that has anything to do with this issue.
   Today is a holiday in the states.  I will try and grab the log if possible tomorrow, but IIRC I was unable to switch VTs after the SEGV.
Comment 3 Chris Lumens 2011-09-05 18:43:16 EDT
What is Workstation 8.0?
Comment 4 Andrew Stiegmann 2011-09-05 19:09:49 EDT
VMware Workstation.  You should be able to reproduce the problem using VMware Player application as it also incorporates Easy Install.
Comment 5 Ales Kozumplik 2011-09-06 02:33:28 EDT
I'm afraid I don't have VMWare software available. If you just tell me the exact ISO (release and architecture) you used I can try to decrypt from the traceback where exactly the sigsegv happened.
Comment 6 Andrew Stiegmann 2011-09-06 14:08:14 EDT
Created attachment 521729 [details]
The anaconda log file.
Comment 7 Andrew Stiegmann 2011-09-06 14:10:29 EDT
Sure.  Below is the ISO information, including an MD5 sum:

ed3a0da651c7687a52b38f74af9d5ec4  ./Fedora-16-Alpha-x86_64-DVD.iso

IIRC I got it from http://download.fedoraproject.org/pub/fedora/linux/releases/test/16-Alpha/Fedora/x86_64/iso/Fedora-16-Alpha-x86_64-DVD.iso

I have also attached the Anaconda log file you requested.  Based on the backtrace it appears that a bad address is being passed into the strdup function.
Comment 8 Ales Kozumplik 2011-09-12 08:37:38 EDT
(In reply to comment #7)
> Sure.  Below is the ISO information, including an MD5 sum:
> 
> ed3a0da651c7687a52b38f74af9d5ec4  ./Fedora-16-Alpha-x86_64-DVD.iso
> 
> IIRC I got it from
> http://download.fedoraproject.org/pub/fedora/linux/releases/test/16-Alpha/Fedora/x86_64/iso/Fedora-16-Alpha-x86_64-DVD.iso
> 
> I have also attached the Anaconda log file you requested.  Based on the
> backtrace it appears that a bad address is being passed into the strdup
> function.

That would point to anaconda version 16.14.6 but I've still had no luck decoding the traceback:

eu-addr2line -e loader 
0x414caa
??:0
0x41532d
??:0
0x40a6af
??:0
0x40b6c9
??:0
Comment 9 Ales Kozumplik 2011-09-12 09:20:11 EDT
Andrew,

can you please attach the screenshot of the segv again, from the f16 alpha dvd that had the ed3a0da651c7687a52b38f74af9d5ec4 (that is the same one I'm trying to match the traceback addresses against). If the matching fails again I'm afraid I won't be able to help you.
Comment 10 Ales Kozumplik 2011-09-12 09:36:00 EDT
Also one thing you can try is using the "devel" parameter on the command line to have coredump created when the sigsegv happens. Then please attach the core file to this bug.
Comment 11 Andrew Stiegmann 2011-09-13 16:16:17 EDT
Created attachment 522995 [details]
Screen shot of the SEGV in the loader
Comment 12 Andrew Stiegmann 2011-09-13 16:27:13 EDT
Created attachment 522998 [details]
Loader core file.

Cores for all!
Comment 13 Andrew Stiegmann 2011-09-13 16:28:31 EDT
Ales,

  I have re-uploaded the screen shot and core file per your request.
Comment 14 Ales Kozumplik 2011-09-19 10:31:02 EDT
(In reply to comment #12)
> Created attachment 522998 [details]
> Loader core file.
> 
> Cores for all!

Thanks for the core that could help somewhat, though maybe we'll have to repeat the exercise with a post-beta compose since I just found today there are no debug symbols in the alpha build (sorry).

I'd like to reproduce your setup here: I noticed you used a kickstart from the cdrom --- how did you put the file in there, i.e. did you remake the iso with the file in?
Comment 15 Andrew Stiegmann 2011-09-19 23:23:51 EDT
(In reply to comment #14)
> I'd like to reproduce your setup here: I noticed you used a kickstart from the
> cdrom --- how did you put the file in there, i.e. did you remake the iso with
> the file in?

Yes... the ISO is a custom made ISO.  Essentially we copy your kernel, initrd, an isolinux.cfg file, an el torito boot image, the kickstart file and a few other files to the ISO image.  Then we use genisoimage to create the whole thing.  Here is the call:

mkisofs -o /path/to/output -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table /path/to/iso/contents
Comment 16 Ales Kozumplik 2011-09-20 08:16:49 EDT
Posted patch that should help us to a more useful tracebacks in the future:

https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00157.html
Comment 17 Ales Kozumplik 2011-09-20 08:20:48 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > I'd like to reproduce your setup here: I noticed you used a kickstart from the
> > cdrom --- how did you put the file in there, i.e. did you remake the iso with
> > the file in?
> 
> Yes... the ISO is a custom made ISO.  Essentially we copy your kernel, initrd,
> an isolinux.cfg file, an el torito boot image, the kickstart file and a few
> other files to the ISO image.  Then we use genisoimage to create the whole
> thing.  Here is the call:
> 
> mkisofs -o /path/to/output -b isolinux/isolinux.bin -c isolinux/boot.cat
> -no-emul-boot -boot-load-size 4 -boot-info-table /path/to/iso/contents

ok this is not very typical and could be the reason why we haven't seen this yet. I'll try to create a similar .iso and boot it here. We'll attack this problem from several fronts.
Comment 18 Ales Kozumplik 2011-09-20 11:48:23 EDT
proposing as a blocker, we at least need to get the debug symbol problems fixed.
Comment 19 Ales Kozumplik 2011-09-20 13:10:47 EDT
Re-enabling anaconda-debuginfo package,
on f16-branch 061bb77abbdea39fcebb88e010ef31a75e9805ce
on master 1703c7bc5efa98cd40f4b410d1649111f6a1a662.
Comment 20 Ales Kozumplik 2011-09-20 13:12:04 EDT
Also I just reproduced this on KVM so this is not VMware specific.
Comment 21 Ales Kozumplik 2011-09-21 07:55:25 EDT
Fix posted:

https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00174.html

Will push after review and when this is an accepted NTH.
Comment 22 Adam Williamson 2011-09-30 15:51:34 EDT
Discussed at 2011-09-30 NTH review meeting. Accepted as NTH - it's an anaconda crash, and we're pretty much automatic +1 nth to any anaconda crash, especially this early.
Comment 23 Ales Kozumplik 2011-10-04 04:15:54 EDT
Fixed on the f16-branch: de985d07c4fa04440f6cc166fab969352aa3fde1
Fixed on master: 136f8196de270a349500ef9aad3e00801dd641ff
Comment 24 Andrew Stiegmann 2011-10-04 17:25:21 EDT
Excellent.  Is there a nightly I can easily grab and test with?  A quick googling shows http://dl.fedoraproject.org/pub/alt/nightly-composes/ but these are from the 30th.  Also they are live images :P.  Thanks.
Comment 25 Ales Kozumplik 2011-10-05 03:25:47 EDT
(In reply to comment #24)
> Excellent.  Is there a nightly I can easily grab and test with?  A quick
> googling shows http://dl.fedoraproject.org/pub/alt/nightly-composes/ but these
> are from the 30th.  Also they are live images :P.  Thanks.

There *should* be a post-beta compose appearing here sometime:

http://serverbeach1.fedoraproject.org/pub/alt/stage/

Make sure to wait for one with anaconda-16.21-1.
Comment 26 Adam Williamson 2011-10-05 03:38:10 EDT
Nothing's going to show up there until Final TC1, which won't be for a bit (week or two, I didn't check yet). I think pub/fedora/linux/development/16 on the mirrors might get updated installer images semi-regularly, I'm not entirely sure.
Comment 27 Brian Lane 2011-10-10 18:30:13 EDT
*** Bug 744341 has been marked as a duplicate of this bug. ***
Comment 28 Adam Williamson 2011-11-02 21:46:14 EDT
We're well past anaconda 16.21 so this should be fixed now. Please re-open if F16 doesn't work (you can pull any of the Final TCs or RCs to test).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.