Bug 73497 - unix domain file system entries cannot be removed after creation.
Summary: unix domain file system entries cannot be removed after creation.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-05 15:01 UTC by george.miller
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 22:55:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unix domain socket creation. (2.11 KB, patch)
2002-09-05 15:42 UTC, george.miller
no flags Details | Diff

Description george.miller 2002-09-05 15:01:09 UTC
Description of Problem:unix domain files system entries cannopt be rm'ed or unlinked.


Version-Release number of selected component (if applicable):


How Reproducible: we have a process that creates a unix domain listening socket (pathname i/tmp/LOGSOCKET). this process is invoked from a 
initd script as su - <username> -c script/process. after this process creates this file system entry, it cannot be removed even by super user.  if the 
process is brought up  from the command line (rather than through the initd script) it is not a problem. the process that creates LOGSOCKET first 
attempts to unlink it (if it is there) so that after a boot it will work (/tmp is reset) and subsequent attempts fail. we can unlink the file within the 
process when the process terminates, but if the process cores or is abnormally terminated, we can never remove the file upon subsequent 
invocations of the process. i have attached some code that will create the unix domain socket.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 george.miller 2002-09-05 15:42:52 UTC
Created attachment 75064 [details]
unix domain socket creation.

Comment 2 Alan Cox 2002-12-15 22:55:31 UTC
Unable to reproduce in current Red Hat - or 7.2



Note You need to log in before you can comment on or make changes to this bug.