This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 735016 - reboot halts after preupgrade
reboot halts after preupgrade
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-01 03:52 EDT by Hongqing Yang
Modified: 2011-09-13 02:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 02:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (1.14 KB, image/png)
2011-09-01 03:52 EDT, Hongqing Yang
no flags Details
grub conf (1.62 KB, text/plain)
2011-09-01 23:15 EDT, Hongqing Yang
no flags Details
preupgrade logs (530.00 KB, text/plain)
2011-09-04 23:26 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-09-01 03:52:16 EDT
Created attachment 520967 [details]
screenshot

Description of problem:
reboot halts after preupgrade

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. preupgrade 
2. boot from upgrade
3. system halts
  
Actual results:


Expected results:


Additional info:
Comment 1 Elad Alfassa 2011-09-01 07:15:10 EDT
Not a preupgrade bug IMO, preupgrade finishes his job once all the packages and installer images are downloaded, and the bootloader config is updated.
Everything after the reboot, if the bootloader was configured correctly, is handled by Anaconda.

Please attach your grub.cfg file, so we could see if the boot parameters are fine.

Proposing as Beta blocker, criteria:
"The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria".




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Elad Alfassa 2011-09-01 07:19:45 EDT
Oh, wait, I didn't read the step to reproduce correctly. 
Do you mean that the upgrade doesn't boot, or that the upgraded system doesn't boot after the upgrade is complete? 




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Hongqing Yang 2011-09-01 23:15:31 EDT
Created attachment 521131 [details]
grub conf

The system halts at the first reboot. the upgrade has not completed.
Comment 4 Elad Alfassa 2011-09-02 03:40:16 EDT
grub configuration looks fine to me. Moving to anaconda.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2011-09-02 13:39:01 EDT
Discussed at 2011-09-02 blocker review meeting. Accepted as a blocker under Beta criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria".

Hongqing, can you please provide preupgrade logs? bcl believes this still may be a preupgrade issue rather than an anaconda one.
Comment 6 Hongqing Yang 2011-09-04 23:26:23 EDT
Created attachment 521423 [details]
preupgrade logs
Comment 7 Brian Lane 2011-09-06 14:57:06 EDT
Back to preupgrade. If it isn't booting after preupgrade sets up grub.conf anaconda isn't involved yet.
Comment 8 Adam Williamson 2011-09-09 15:07:44 EDT
Richard, can you please look into this? It's a Beta blocker, and all accepted beta blockers need to be addressed by 09-15 to get the RC out on time. thanks!
Comment 9 Richard Hughes 2011-09-12 15:45:38 EDT
Maybe a crazy questions; does preupgrade have to use grub2 now?
Comment 10 Will Woods 2011-09-12 17:45:48 EDT
It shouldn't? The only way preupgrade messes with the bootloader is by using grubby:

Add new entry:
  /sbin/grubby --title="%s" --remove-kernel="%s" --add-kernel="%s" --initrd="%s"

Remove entry:
  /sbin/grubby --remove-kernel="%s"

If grubby's deprecated/broken we might need to change those commands, but preupgrade doesn't touch the bootloader config itself.
Comment 11 Adam Williamson 2011-09-12 18:57:23 EDT
since preupgrade is only operating on the F15 (or F14) system it shouldn't matter what F16 is doing with grub2, right? i mean, the grubby it runs is from f15, not f16, right? so...short answer, I don't think preupgrade has to worry about grub2 at all for f15. unless I miss something.
Comment 12 Adam Williamson 2011-09-12 19:02:04 EDT
I actually just tested and couldn't reproduce Hongqing's bug: preupgrade stage completed, it rebooted happily into anaconda, and anaconda is grinding away installing packages ATM. I expect it to fail at bootloader stage with the known bug there, but I didn't see what Hongqing sees.

So, a question occurs: as far as we know, preupgrade can't work until you hack around https://bugzilla.redhat.com/show_bug.cgi?id=728193 . So we kinda need to know how Hongqing got around that. Nirik said that for a few days, the development/16 tree didn't have boot images in it at all, which could explain the problem. Now it does, and as I said, for me, a simple preupgrade seems to be working. (I just installed a clean F15, downloaded and 'corrected' releases.txt by changing Fedora/16/ to 16/, and ran preupgrade).

Hongqing, could you try again, see if you can still reproduce this, and if so, give more details on precisely what procedure you followed? If anyone else can test that would also help. Thanks!
Comment 13 Adam Williamson 2011-09-12 19:29:43 EDT
so my preupgrade actually completed without bootloader errors and booted into an F16 system, although with grub1 and with the F15 kernel. but I definitely didn't hit this bug.
Comment 14 Hongqing Yang 2011-09-13 02:09:27 EDT
(In reply to comment #13)
> so my preupgrade actually completed without bootloader errors and booted into
> an F16 system, although with grub1 and with the F15 kernel. but I definitely
> didn't hit this bug.
 
I did not hit this on f16-beta-tc2. I would like to close this one. And I hit bug 737731

Note You need to log in before you can comment on or make changes to this bug.