Bug 735018 - qemu-kvm will be aborted with core dumped when boot guest has ehci and uhci storage attached simultaneous
Summary: qemu-kvm will be aborted with core dumped when boot guest has ehci and uhci s...
Keywords:
Status: CLOSED DUPLICATE of bug 734995
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 07:57 UTC by juzhang
Modified: 2011-09-02 07:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 07:18:42 UTC


Attachments (Terms of Use)

Description juzhang 2011-09-01 07:57:31 UTC
Description of problem:
Boot guest with ehci and uhci storage attached simultaneous,qemu-kvm will be aborted with core dumped 

Version-Release number of selected component (if applicable):
qemu-kvm-tools-0.12.1.2-2.184.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest
#/usr/libexec/qemu-kvm -M rhel6.2.0 -enable-kvm -m 2G -smp 2,cores=2,threads=1,sockets=1  -name RHEL6.1_32 -uuid 50eba0fa-c3bc-4634-9c87-e46fc4dafab9 -rtc base=utc,clock=host,driftfix=slew -boot c -drive file=/root/zhangjunyi/RHEL6.1_64-copy-2.qcow2,if=none,id=drive-ide-0-0,media=disk,format=qcow2,cache=none,werror=stop,index=0 -device virtio-blk-pci,drive=drive-ide-0-0,id=ide0-0-0,physical_block_size=4096,logical_block_size=512,bootindex=1 -netdev tap,id=hostnet1,vhost=on,sndbuf=0 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=78:2B:CB:AF:11:11 -vnc :10 -monitor stdio -device virtio-balloon-pci,id=balloon0 
/
-device usb-ehci,id=ehci 
-device usb-storage,bus=ehci.0,drive=usbstick1 
-drive if=none,id=usbstick1,file=/root/zhangjunyi/usbdevice1.qcow2 
/
-usb 
-device usb-storage,bus=usb.0,drive=usbstick2
-drive if=none,id=usbstick2,file=/root/zhangjunyi/usbdevice2.qcow2 

2.
3.
  
Actual results:
After step1
qemu-kvm: savevm.c:1258: vmstate_register: Assertion `!se->compat || se->instance_id == 0' failed.
Aborted (core dumped)

Expected results:
Works well

Additional info:
(gdb) bt
#0  0x0000003887a32945 in raise () from /lib64/libc.so.6
#1  0x0000003887a34125 in abort () from /lib64/libc.so.6
#2  0x0000003887a2b9fe in __assert_fail_base () from /lib64/libc.so.6
#3  0x0000003887a2bac0 in __assert_fail () from /lib64/libc.so.6
#4  0x00000000004bee31 in vmstate_register (dev=<value optimized out>, instance_id=<value optimized out>, vmsd=<value optimized out>, 
    opaque=<value optimized out>) at savevm.c:1258
#5  0x00000000004c273f in qdev_init (dev=0x32b0460) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qdev.c:288
#6  0x00000000004c2a99 in qdev_device_add (opts=0x23e15b0) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qdev.c:253
#7  0x0000000000409629 in device_init_func (opts=<value optimized out>, opaque=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4574
#8  0x000000000047a28a in qemu_opts_foreach (list=<value optimized out>, func=0x409620 <device_init_func>, opaque=0x0, 
    abort_on_failure=<value optimized out>) at qemu-option.c:957
#9  0x000000000040d2e8 in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6107

Comment 1 juzhang 2011-09-01 07:59:00 UTC
Also tested with qemu-kvm-tools-0.12.1.2-2.179.el6.x86_64,guest can be booted successful. mark this issue as regression

Comment 3 Gerd Hoffmann 2011-09-02 07:18:42 UTC

*** This bug has been marked as a duplicate of bug 734995 ***


Note You need to log in before you can comment on or make changes to this bug.