This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 735027 - Failed to install repository NFSISO default
Failed to install repository NFSISO default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-01 04:27 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-02 14:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error log of anaconda 16.16 (15.29 KB, text/x-log)
2011-09-01 04:27 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2011-09-01 04:27:16 EDT
Created attachment 520975 [details]
error log of anaconda 16.16

Description of problem:
anaconda failed to install repository NFSISO default, refer to the link:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_default

Version-Release number of selected component (if applicable):
16.16

How reproducible:
always

Steps to Reproduce:
1.Boot the installer using any available means (netinst.iso, pxeboot images or DVD.iso) 
2.Direct anaconda to use NFS as the installation type by adding the boot command: askmethod
3.Choose NFS directory as Installation method when prompted.
4.Provide a nfs server and path to where your DVD.iso image is stored. 
5.Proceed with installation 
  
Actual results:
anaconda crashed.

Expected results:
Install completes successfully.

Additional info:
Comment 1 Adam Williamson 2011-09-01 12:19:27 EDT
Just out of curiosity, why did you use the Alpha ISO for testing rather than the Beta TC1 ISO? I can't see that it would be relevant to the crash, but it jumped out at me from the logs.

Right now this is kind of ambiguous between Beta and Final blocker according to the criteria - Beta says "The installer must be able to use the HTTP, FTP and NFS remote package source options", Final says "The installer must be able to use all supported local and remote package source options" - but I believe we intended NFS ISO to be considered different from NFS, and come under Final, so proposing as a Final blocker and Beta NTH.
Comment 2 Tao Wu 2011-09-02 05:04:22 EDT
(In reply to comment #1)
> Just out of curiosity, why did you use the Alpha ISO for testing rather than
> the Beta TC1 ISO? I can't see that it would be relevant to the crash, but it
> jumped out at me from the logs.
> 

Thanks for pointing out this mistake, I didn't see the 'Don't mix images' warning on:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_default

which require the exact architecture ... and I have retested the case again with a Beta TC1 ISO, which did not crash any more, but still meet this bug#727522.

> Right now this is kind of ambiguous between Beta and Final blocker according to
> the criteria - Beta says "The installer must be able to use the HTTP, FTP and
> NFS remote package source options", Final says "The installer must be able to
> use all supported local and remote package source options" - but I believe we
> intended NFS ISO to be considered different from NFS, and come under Final, so
> proposing as a Final blocker and Beta NTH.

Yes, it would be better to set this as a Final blocker, because it is not so urgent at this stage according to the criteria.
Comment 3 Adam Williamson 2011-09-02 14:53:05 EDT
Discussed at 2011-09-02 NTH review meeting. It looks like this specific bug is invalid, caused by pilot error; the remaining bug is already reported and should be followed at https://bugzilla.redhat.com/show_bug.cgi?id=727522 . Closing. Tao, if I missed something, please re-open. thanks!
Comment 4 Adam Williamson 2011-09-06 14:42:04 EDT
So, 727522 is supposed to be fixed in Beta TC1, and the other NFS tests did pass...so if you hit the error from 727522 doing an NFS-ISO install of Beta TC1, I guess that's actually a slightly different bug. Is that what happened?

Note You need to log in before you can comment on or make changes to this bug.