Bug 735029 - avc denial during using cimconfig
Summary: avc denial during using cimconfig
Keywords:
Status: CLOSED DUPLICATE of bug 723977
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 08:36 UTC by Petr Sklenar ⛄
Modified: 2012-10-16 08:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-05 06:34:38 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2011-09-01 08:36:36 UTC
Description of problem:
avc denial during using cimconfig.

Version-Release number of selected component (if applicable):
tog-pegasus-2.11.0-2.el6.i686 

selinux-policy-3.7.19-108.el6.noarch
libselinux-devel-2.0.94-5.el6.i686
libselinux-2.0.94-5.el6.i686
selinux-policy-targeted-3.7.19-108.el6.noarch
libselinux-utils-2.0.94-5.el6.i686

How reproducible:
deterministic

Steps to Reproduce:
# cimconfig -u shutdownTimeout -p
Failed to unset the config property.CIM_ERR_FAILED: Failed to save
configuration properties to file: cannot rename file:
/etc/Pegasus/cimserver_planned.conf. Configuration property not set

type=AVC msg=audit(1314864301.329:244886): avc:  denied  { rename } for 
pid=12475 comm="cimserver" name="cimserver_planned.conf" dev=dm-0 ino=132074
scontext=unconfined_u:system_r:pegasus_t:s0
tcontext=system_u:object_r:pegasus_conf_t:s0 tclass=file
  
Actual results:
avc denial

Expected results:
no denial

Additional info:

Comment 2 Miroslav Grepl 2011-09-05 06:34:38 UTC
Should be fixed in the latest RHEL6 policy.

*** This bug has been marked as a duplicate of bug 723977 ***


Note You need to log in before you can comment on or make changes to this bug.