Bug 735064 - [RFE] add new task to recipe after it run
Summary: [RFE] add new task to recipe after it run
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Community
Component: scheduler
Version: 0.7
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: future_maint
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 10:34 UTC by Juraj Marko
Modified: 2015-09-01 03:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-28 01:20:37 UTC


Attachments (Terms of Use)

Description Juraj Marko 2011-09-01 10:34:08 UTC
Description of problem:
It will be nice to have a way to add task to running job in beaker. It will be used during debugging tests. Many test have different  behavior when they run in beaker and on reserved machine. And 1 run of beaker test takes minimal 30minutes even if the test takes only few seconds. I think it will work so that I run test  and after this test I run reservesys. When the test is finish i will see the result, do some changes and add to recipe the new version of this test and a reservesys. It will save the time which machines use for installing system.
  
Actual results:
When the recipe once run there is no way to add new task to this recipe during the run. You must take new machine and wait for installation

Expected results:
You can add new tasks to running task and save installation time

Comment 1 Dan Callaghan 2012-09-28 01:20:37 UTC
Jobs are immutable once submitted, it's not practical for Beaker to allow extra tasks to be inserted after the fact.

Note that you can conditionally reserve a system if earlier tasks fail by passing RESERVE_IF_FAIL=1 to /distribution/reservesys (see bug 623933).

Comment 3 Dan Callaghan 2012-10-01 22:36:27 UTC
You could log in to the system you have reserved and update the task manually (either by editing the files directly or using yum/rpm to install a new version of the task rpm) and then re-run it:

    cd /mnt/tests/distribution/something
    make run


Note You need to log in before you can comment on or make changes to this bug.