Bug 735070 - Logs are written to /var/log/nova/nova-$service.log instead of /var/log/nova/$service.log
Summary: Logs are written to /var/log/nova/nova-$service.log instead of /var/log/nova/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openstack-nova
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 10:54 UTC by Mark McLoughlin
Modified: 2011-09-30 19:43 UTC (History)
3 users (show)

Fixed In Version: openstack-nova-2011.3-0.8.d4.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-30 19:43:29 UTC


Attachments (Terms of Use)

Description Mark McLoughlin 2011-09-01 10:54:17 UTC
Since the switch to systemd, logs have been written to nova-$service.log even though the commands we use to launch them are e.g.

  /usr/bin/nova-compute --flag-file /etc/nova/nova.conf --logfile /var/log/nova/compute.log

It turns out the issue is that it should be --flagfile instead of --flag-file and the difference is causing --logfile to be ignored

Comment 1 Fedora Update System 2011-09-01 11:09:46 UTC
openstack-nova-2011.3-0.6.d4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-0.6.d4.fc16

Comment 2 Fedora Update System 2011-09-01 19:01:44 UTC
Package openstack-nova-2011.3-0.6.d4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-nova-2011.3-0.6.d4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-0.6.d4.fc16
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-09-05 07:14:56 UTC
openstack-nova-2011.3-0.8.d4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-0.8.d4.fc16

Comment 4 Fedora Update System 2011-09-30 19:43:19 UTC
openstack-nova-2011.3-0.8.d4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.