Bug 735075 - Firefox becomes irresponsive with CPU thrashing
Summary: Firefox becomes irresponsive with CPU thrashing
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 11:04 UTC by Tiago
Modified: 2018-04-11 10:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-03 15:00:46 UTC


Attachments (Terms of Use)

Description Tiago 2011-09-01 11:04:54 UTC
Description of problem: Firefox becomes unresponsive forever with intense CPU thrashing if some actions are taken, as described below.



Version-Release number of selected component (if applicable): 6.0-1


How reproducible: always reproducible, by taking one of the steps below.


Steps to Reproduce:
* Choose "Print Preview" from file menu; or
* Choose "Image Properties" from an image's context menu.
  
Actual results:
As mentioned before, the software becomes unresponsive with very high CPU time thrashing.

Expected results:
Open a dialog box.

Additional info:

Comment 1 Tiago 2011-09-01 11:12:13 UTC
errata: instead of "Image Properties", it must be read "View Image Info"
It also occurs when select "View Page Properties" from both context or "Tools" menu
"Print Preview" can perform successfully in some pages.

Comment 2 Tiago 2011-09-01 11:18:05 UTC
disabling all extensions, plugins, localization and themes won't change anything in this misbehavior

Comment 3 Elad Alfassa 2011-09-01 12:33:48 UTC
Can't reproduce here.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Matěj Cepl 2011-09-02 20:04:31 UTC
(In reply to comment #3)
> Can't reproduce here.

That isn't helpful. We have to either find the way how to reproduce this, or to find what did reporter wrong that he is getting into this situation without Firefox bug. Just the fact, that you cannot reproduce it, doesn't mean much to anybody.

Comment 5 Matěj Cepl 2011-09-02 20:17:20 UTC
(In reply to comment #2)
> disabling all extensions, plugins, localization and themes won't change
> anything in this misbehavior

So, after a bug zapper training extempore, let's return back to this bug.

However, I cannot reproduce here with firefox-6.0-1.fc16.x86_64. So, we need more information to be able to reproduce the issue here.

1) Are you able to reproduce this when running firefox in the safe mode (i.e., run it with parameter -safe-mode on the command line)? That's basically what you were trying to do with switching off plugins etc., just may have missed something.
2) Are you able to reproduce the problem with the upstream binary from
http://www.firefox.com/?
3) Are you able to reproduce the problem with a fresh profile? (run command
firefox -no-remote -P
and define new profile (later you can remove it again)

Thank you for your cooperation and helping to make Fedora more awesome!

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 6 Martin Stransky 2012-05-03 15:00:46 UTC
Reporter, please reopen if you have the requested info. Thanks!


Note You need to log in before you can comment on or make changes to this bug.