Bug 735080 - Cannot pass timeout to Connection.open()
Summary: Cannot pass timeout to Connection.open()
Keywords:
Status: CLOSED DUPLICATE of bug 908224
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 11:25 UTC by Raymond Mancy
Modified: 2014-12-08 01:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-27 10:45:02 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2011-09-01 11:25:58 UTC
Description of problem:

Cannot specify a timeout when trying to open a connection

Version-Release number of selected component (if applicable):

python-qpid 0.10

How reproducible:

everytime

Steps to Reproduce:
1. Try opening a connection to a broker that does not exist 
  
Actual results:
Connection just hangs forever

Expected results:
The ability to specify a timeout

Additional info:

Looking through this qpid.messaging.endpoints code I noticed this on line 261.

  self._ewait(lambda: self._transport_connected and not self._unlinked())

It never seems to pass the timeout kwarg to _ewait that has the following signiture:

  def _ewait(self, predicate, timeout=None)

Comment 1 Justin Ross 2013-02-27 10:45:02 UTC

*** This bug has been marked as a duplicate of bug 908224 ***


Note You need to log in before you can comment on or make changes to this bug.