Bug 735081 - [gnome-shell] aborts user session on start-up
Summary: [gnome-shell] aborts user session on start-up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libgee
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 11:34 UTC by Joachim Frieben
Modified: 2011-09-10 00:29 UTC (History)
7 users (show)

Fixed In Version: libgee-0.6.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-10 00:29:11 UTC


Attachments (Terms of Use)
Log file .xession-errors after failed login attempt (6.79 KB, text/plain)
2011-09-01 11:35 UTC, Joachim Frieben
no flags Details
Log file .xession-errors for libgee-0.6.1-3.fc16 (6.96 KB, text/plain)
2011-09-01 19:24 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2011-09-01 11:34:42 UTC
Description of problem:
After upgrading to the latest gnome-shell package, the GNOME desktop fails to start up. Instead, a message that something went wrong and a button prompting the user for logging out are displayed.

Version-Release number of selected component (if applicable):
gnome-shell-3.1.90.1-1.fc16.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Launch GNOME shell from GDM.
  
Actual results:
GNOME session aborts.

Expected results:
GNOME session starts successfully.

Additional info:
None.

Comment 1 Joachim Frieben 2011-09-01 11:35:40 UTC
Created attachment 520993 [details]
Log file .xession-errors after failed login attempt

Comment 2 Joachim Frieben 2011-09-01 11:37:21 UTC
Installed packages include clutter-1.7.12-1.fc16.

Comment 3 Kalev Lember 2011-09-01 14:47:59 UTC
Looking at the log, the error message is:
Error: Requiring Shell, version none: Typelib file for namespace 'Gee', version '1.0' not found

I managed to reproduce it on my system after removing libgee-devel.

It would appear to be a packaging bug with libgee-0.6.1-2.fc15: the typelib is currently in the -devel package, but should instead be in the main package so that apps like gnome-shell could use the library with GObject introspection without needing to depend on the -devel package.

Comment 4 Fedora Update System 2011-09-01 16:00:06 UTC
libgee-0.6.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libgee-0.6.1-3.fc15

Comment 5 Michel Alexandre Salim 2011-09-01 16:10:46 UTC
libgee-0.6.1-3.fc16 is built, but I'd rather it be pushed together with the GNOME stack update, rather than as a stand-alone update

Comment 6 Joachim Frieben 2011-09-01 19:24:25 UTC
Created attachment 521083 [details]
Log file .xession-errors for libgee-0.6.1-3.fc16

GNOME shell still fails after upgrading to libgee-0.6.1-3.fc16 albeit with a slightly different error message.

Comment 7 Kalev Lember 2011-09-01 19:34:52 UTC
Do you have new enough mutter?

Comment 8 Fedora Update System 2011-09-02 05:23:33 UTC
Package libgee-0.6.1-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgee-0.6.1-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libgee-0.6.1-3.fc15
then log in and leave karma (feedback).

Comment 9 Joachim Frieben 2011-09-02 06:12:51 UTC
After ugrading to mutter-3.1.90.1-1.fc16, too, the issue is resolved.

Comment 10 Fedora Update System 2011-09-10 00:29:05 UTC
libgee-0.6.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.