Bug 735196 - Dovecot systemV init scripts look broken
Summary: Dovecot systemV init scripts look broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 18:38 UTC by Martí­n Marqués
Modified: 2011-09-09 08:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 08:02:31 UTC


Attachments (Terms of Use)

Description Martí­n Marqués 2011-09-01 18:38:19 UTC
Description of problem:

Dovecot's init.d script works (start, stop, etc.) but can't be set correctly via chkconfig, setup or system-config-services (dovecot service just doesn't appear in the latter ones).

Version-Release number of selected component (if applicable):

dovecot-2.0.13-1.fc15.x86_64

How reproducible:

# chkconfig dovecot --list

Nota: Este resultado muestra solo los srvicios SysV y no incluye servicios 
      nativos systemd. Los datos de configuración de SysV podrían ser
      sobreescritos por la configuración nativa de systemd.

#

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Hlavinka 2011-09-09 08:02:31 UTC
That's expected behaviour. You have explanation in chkconfig output. Dovecot uses systemd service files instead of SysV init script since Fedora 15.

> Dovecot's init.d script works (start, stop, etc.) but can't be set 
> correctly via chkconfig

chkconfig dovecot on 
should work:
# chkconfig dovecot off
Note: Forwarding request to 'systemctl disable dovecot.service'.
rm '/etc/systemd/system/multi-user.target.wants/dovecot.service'

chkconfig works as compatibility layer in this case. It does not support all commands. See 
https://fedoraproject.org/wiki/SysVinit_to_Systemd_Cheatsheet#Services


Note You need to log in before you can comment on or make changes to this bug.