Bug 73520 - (Rage 128) X hangs when resizing acrobat
(Rage 128) X hangs when resizing acrobat
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82779
  Show dependency treegraph
 
Reported: 2002-09-05 14:00 EDT by Bryn Jeffries
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-6.7.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 01:50:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree log up to point of hang (24.51 KB, text/plain)
2002-09-09 06:08 EDT, Bryn Jeffries
no flags Details
XFree86 configuration file (1.97 KB, text/plain)
2002-09-09 06:09 EDT, Bryn Jeffries
no flags Details
X config file (28.30 KB, text/plain)
2002-10-28 08:26 EST, Tamas Arpad
no flags Details
This is the real config file for X (the other was the log of course) (3.28 KB, text/plain)
2002-10-28 08:28 EST, Tamas Arpad
no flags Details
XF86Config (enabled dri, disabled accel for r128) (3.29 KB, text/plain)
2002-11-13 13:04 EST, Tamas Arpad
no flags Details

  None (edit)
Description Bryn Jeffries 2002-09-05 14:00:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
Upon resizing certain windows (occasionally xdvi, and most frequently Adobe
Acrobat), the screen completely hangs with the exception that the mouse pointer
can still move. No interaction with the screen is possible, and the keyboard is
unresponsive. Upon ssh'ing remotely into the machine X appears to by taking up
99.5% CPU usage. kill -9 as root succeeds in restarting gdm and keyboard allows
me to log back in locally. Resizing gets as far as the window dimensions
appearing on the screen before it hangs.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start X (I use gbm on startup to log in)
2. Run Adobe Acrobat and load a pdf
3. Drag bottom-right corner of window outwards.
	

Actual Results:  Window dimensions appear, and screen promptly hangs as
described above.

Expected Results:  Window should have resized and allowed continued operation.

Additional info:
Comment 1 Bryn Jeffries 2002-09-06 11:28:36 EDT
I have since had the same problem when resizing gv (ghostview) window, and
immediately upon starting ggv (GNOME version of gv).
Comment 2 Mike A. Harris 2002-09-07 03:57:04 EDT
Attach X log and config individually using link below.
Comment 3 Bryn Jeffries 2002-09-09 06:08:03 EDT
Created attachment 75544 [details]
XFree log up to point of hang
Comment 4 Bryn Jeffries 2002-09-09 06:09:52 EDT
Created attachment 75545 [details]
XFree86 configuration file
Comment 5 Bryn Jeffries 2002-09-09 06:12:27 EDT
In producing the logfile I found that acrobat does not always make X hang. I
needed to have Galeon running at the same time - I haven't noticed this before
since Galeon is normally always running.
Comment 6 Bryn Jeffries 2002-09-12 15:03:31 EDT
The condition seems to occur for a wide range of applications. I have had the
same problem with the following:
Importing data into Gnumeric
Changing preferences in Galeon
Looking up a word in GDict
Changing desktop properties on Gnome Desktop

The above seem to indicate that the problem is linked to GNOME or Gtk.I do not
recall having any such problems with Redhat 7.2.
Comment 7 Bryn Jeffries 2002-09-16 10:44:47 EDT
Despite efforts to work around this problem, my machine is too unstable at
present. Is there any way in which I can provide information that will bring
about a swifter resolution? Perhaps I can run a debugging utility on X? I'd
appreciate any suggestions.
Comment 8 Tamas Arpad 2002-10-28 08:24:41 EST
The same happens with my system too. I had rh7.0 and had the problem relatively
rare (2-3 times a week) and installed rh8 because I thought it will solve the
problem, now I have two restart X 2-3 times a day!
I found that the hang happens when I'm trying to resize, move or scroll a window.
I'll attach my log and config files.
Comment 9 Tamas Arpad 2002-10-28 08:26:06 EST
Created attachment 82369 [details]
X config file
Comment 10 Tamas Arpad 2002-10-28 08:28:01 EST
Created attachment 82370 [details]
This is the real config file for X (the other was the log of course)
Comment 11 Bryn Jeffries 2002-10-28 08:31:00 EST
I found that you don't get crashes if you disable the dri module in XF86 config
file (put a # before load "dri"). That's all I can suggest, I'm afraid.
Comment 12 Tamas Arpad 2002-11-06 03:36:58 EST
I also disabled dri one week ago and it seems to be stable for me too.
Thanks for the idea.
Comment 13 Mike A. Harris 2002-11-06 06:39:41 EST
My apologies for not responding sooner.  There are so many XFree86 bug
reports, it's easy to get lost in them sometimes.

It sounds to me like there is a 2D acceleration glitch of some kind going on.
You've stated disabling DRI solves the problem.  Can you re-enable DRI, and
use Option "noaccel" in the device section of the X config file instead?

If that also works around the problem, we can further refine it down to
the offending problem.

Another thing that would greatly help me, would be if anyone who encounters
this problem could test out Red Hat Linux 8.0 and see if it also has this
problem.  I've also got RPM's of XFree86 4.2.1 on ftp://people.redhat.com
for 8.0 in my testing directory which will be released as erratum in the
near future.  If someone could test those, that would be useful.  If none
of these solve the problem, for the really really brave, I've got XFree86
CVS RPM's also on people.r.c in the live-grenades directory for testing.

Any feedback that anyone can provide on any/all of the above suggestions
would be very useful.  I will be releasing 7.3 erratum soon, so if I can
gather info to fix this problem for you, I'd like to make sure it is fixed.

Thanks
Comment 14 Tamas Arpad 2002-11-13 13:02:28 EST
I reenabled dri, and wrote Option "noaccel" into the r128 driver 
section. By the way I'm using Redhat 8.0. One reason for the update was 
this bug, but it didn't disappear unfortunately.
I'll attach my xf86config-4 too.
Comment 15 Tamas Arpad 2002-11-13 13:04:52 EST
Created attachment 84865 [details]
XF86Config (enabled dri, disabled accel for r128)
Comment 16 Bryn Jeffries 2003-01-31 06:51:42 EST
Just an update...

I've just upgraded my machine to RH 8.0, and applied all updates. I suffered a
similar crash (using gphoto) as before. I have now downloaded the suggested
updates from
ftp://people.redhat.com/mharris/testing/8.0/XFree86/4.2.1-10.5/i386/ and will
give these a go. Fingers crossed they do the trick.
Comment 17 Mike A. Harris 2004-07-12 01:50:17 EDT
Assuming the new X packages did the trick in comment #16 above,
and closing bug as CURRENTRELEASE.  If the problem recurs, please
upgrade to Fedora Core 2 or Red Hat Enterprise Linux 3, and update
each to the latest erratum to test if these new OS releases resolve
the issue. If the problem persists, please reopen the report with
updated information, config/log files, etc.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.