Bug 73522 - RFE: Ensure SRPM availability
Summary: RFE: Ensure SRPM availability
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-05 18:07 UTC by Bill Rugolsky, Jr.
Modified: 2007-10-24 02:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 16:08:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Rugolsky, Jr. 2002-09-05 18:07:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
A number of packages in the Null beta updates do not have SRPMS, including
kernel-2.4.18-14, glibc-2.2.93-2, and XFree86-4.2.0-67.6. SRPMS and RPMS should
generally be made available simultaneously, particularly for GPL packages.
[IANAL, and this is beta, but it is generally good policy.]  In some
circumstances, an SRPM may be inappropriate (e.g, jdk); then an explicit
override or a .nosrc.rpm should be required before adding a package to a channel.

Also, unless I'm missing something, I see no easy way to simply get
all of the SRPMS for the RPMS that are installed on my system *after*  I've updated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Linux Null Beta
2. up2date --register
3. up2date-nox -u -d --src --nosig
	

Actual Results:  File Not Fount: r-e-d.a

Error Message:
    Invalid RPM package kernel-2.4.18-14.src.rpm requested
Error Class Code: 17
Error Class Info: File not found.

Additional info:

Comment 1 Mihai Ibanescu 2003-01-15 16:08:48 UTC
All the packages have srpms attached. My feeling is Null was somehow busted in
that respect. Since Null is long gone now, I'll close this bug. Feel free to
reopen it or submit an enhancement request for downloading source rpms even if
your system is up-to-date.


Note You need to log in before you can comment on or make changes to this bug.