Bug 735236 - NetworkManager doesn't remove IPv6 addresses from downed connections
Summary: NetworkManager doesn't remove IPv6 addresses from downed connections
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 21:28 UTC by Wolfgang Rupprecht
Modified: 2012-05-11 04:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-03 19:15:08 UTC


Attachments (Terms of Use)

Description Wolfgang Rupprecht 2011-09-01 21:28:11 UTC
Description of problem:

NetworkManager doesn't remove stale IPv6 addresses when the ethernet cable is unplugged.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Plug a laptop with wifi and an ethernet nic into an IPv6 capable ethernet.
2. unplug the ethernet again.
3. run ifconfig and notice that the IPv6 addresses are still active on that interface and routes through that interface are still in the routing table.
4. try to connect to an IPv6 host and notice the packets all go to the disconnected interface instead of the still connected wifi. 
  
Actual results:
the disconnected ethernet interface still has an IPv6 address, the routes via that interface are still in the routing table and the interface is still marked as up.

Expected results:
The interface would be marked as down.  The routes via that interface would be removed and the IPv6 addresses assigned to that interface would be removed.

Additional info:

Comment 1 Wolfgang Rupprecht 2011-09-01 21:30:53 UTC
Version-Release number of selected component (if applicable):

NetworkManager.x86_64           1:0.8.9997-6.git20110721.fc15

Comment 2 Wolfgang Rupprecht 2011-09-01 21:33:28 UTC
Workaround:

 service NetworkManager restart

Restarting NetworkManager will clear up the problem.

Comment 3 Zdenek Kabelac 2012-01-03 09:50:19 UTC
IMHO there are more IPv6 related problems still even with latest Rawhide version:

NetworkManager-0.9.2-2.fc17.x86_64


wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500  metric 1
        inet6 fe80::21c:bfff:fe03:287  prefixlen 64  scopeid 0x20<link>
        ether 00:1c:bf:03:02:87  txqueuelen 1000  (Ethernet)
        RX packets 3635548  bytes 5205532011 (4.8 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2384992  bytes 251413834 (239.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

here can be seen that disconnected wlan connection has still assigned some IPv6 address - the funniest part is - it has not be given this address since my home router has ipv6 support disabled.

Also NM seems to 'ignore'   nm-connection-editor  settings to 'ignore' IPV6.
Thus I'm having IPv6 address assigned to my eth0 connection - while my kernel has disabled all ipv6 related modules via:

alias net-pf-10 off
blacklist ipv6

Comment 4 Dan Winship 2012-05-03 19:13:58 UTC
(In reply to comment #3)
> IMHO there are more IPv6 related problems still even with latest Rawhide
> version:

This is not the same as the original bug report

> here can be seen that disconnected wlan connection has still assigned some IPv6
> address - the funniest part is - it has not be given this address since my home
> router has ipv6 support disabled.

fe80:: addresses are link-local addresses and are automatically assigned by the kernel when IPv6 is enabled

> Also NM seems to 'ignore'   nm-connection-editor  settings to 'ignore' IPV6.
> Thus I'm having IPv6 address assigned to my eth0 connection - while my kernel
> has disabled all ipv6 related modules via:

NM is ignoring the device. It's the kernel that's adding that address. I'm not sure what you're doing wrong with the module blacklist, but it's apparently not working.

Comment 5 Dan Winship 2012-05-03 19:15:08 UTC
(In reply to comment #0)
> NetworkManager doesn't remove stale IPv6 addresses when the ethernet cable is
> unplugged.

I just tested, and this works fine in F17... must have gotten fixed at some point and no one noticed this bug.

Comment 6 Wolfgang Rupprecht 2012-05-11 04:09:22 UTC
It looks fixed on F16 x86_64 too.


Note You need to log in before you can comment on or make changes to this bug.