Bug 735251 - Marvell 88SE91xx SATA 3 (6 Gbps) controller not detected
Summary: Marvell 88SE91xx SATA 3 (6 Gbps) controller not detected
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 00:45 UTC by Marlos de Mendonça Corrêa
Modified: 2017-01-21 14:39 UTC (History)
7 users (show)

See Also:
Fixed In Version: 25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-21 14:39:40 UTC


Attachments (Terms of Use)
Workaround for Marvell 88SE91xx (127 bytes, text/plain)
2013-01-27 13:35 UTC, Marlos de Mendonça Corrêa
no flags Details
Add device id for Marvell 88se91a2 (805 bytes, patch)
2017-01-20 14:59 UTC, Marlos de Mendonça Corrêa
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Linux Kernel 34832 None None None Never
Red Hat Bugzilla 757166 None None None Never
Red Hat Bugzilla 1062463 None None None Never

Internal Links: 1062463

Description Marlos de Mendonça Corrêa 2011-09-02 00:45:52 UTC
Description of problem:
I can`t install Fedora 15 on my Asus Rampage III Black Edition because the SATA 3 HDs arent detected.

Version-Release number of selected component (if applicable):
Fedora 15 - Kernels 2.6.38 - 2.6.40


Reproductibility: Install/Run (Live) Fedora 15 on Asus Rampage III Black Edition (wich has Marvell 88SE91xx SATA 3) and try to detect HDs (2x WDC SATA 3 Velociraptor as RAID 0) on SATA 3 port

  
Actual results: Controller is exhibited with lspci, but none of their HDs are detected. Logs don`t show nothing regardind the SATA 6 HDs


Expected results:
That HDs are properly detected.


Additional info:
None for now.

Comment 1 Josh Boyer 2011-10-20 18:46:24 UTC
Do you have this set to AHCI mode in the BIOS?

Can you post the dmesg from the install attempt?

Have you tried the Fedora 16 Beta release at all?

Comment 2 Marlos de Mendonça Corrêa 2012-05-30 22:31:17 UTC
Sorry by may lack of contact, but the problem still persists.

Doing a lot o research, I`ve been capable to find some clues.

As pointed here ( http://en.wikipedia.org/wiki/List_of_Marvell_Technology_Group_chipsets#88SE91xx_Chipsets_Linux_support ), if I do /bin/echo 1b4b 91a2 > /sys/bus/pci/drivers/ahci/new_id my SATA Controller is recognized and I my HDs, despite the raid, are recognized.

My Marvell SATA 6Gbps  is set to RAID mode in BIOS, but, this is not a problem. After the command above, I just need to do dmraid -s and my raid show up.

Comment 3 Dave Jones 2012-10-23 15:38:00 UTC
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).

Comment 4 Justin M. Forbes 2012-11-14 16:24:22 UTC
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.

Comment 5 Marlos de Mendonça Corrêa 2013-01-26 22:23:21 UTC
Sorry! This bug has still been a issue. It happend with Fedora 16, 17 and now, 18. As I mentioned before, if I do /bin/echo 1b4b 91a2 > /sys/bus/pci/drivers/ahci/new_id, I can see the following error in /var/log/messages, repeated 5 times: device-mapper: ioctl: device doesn't appear to be in the dev hash table. But, despite of that, my disks becomes accessible then I can mount, format, resize, etc...

I'm trying hard to install Fedora 18 on the disks on my Marvell Sata controller. During the install process, I can use this trick to install Fedora, but it doesn't initialize.

I've found the following infos about Marvell Sata 88SE91xx family:

http://en.wikipedia.org/wiki/List_of_Marvell_Technology_Group_chipsets#88SE91xx_SATA.2FIDE_controllers_chipsets
https://bugzilla.kernel.org/show_bug.cgi?id=34832
http://www.spinics.net/lists/linux-pci/msg19117.html

In some point I've found a suggestion to create a file called marvell.modules in /etc/sysconfig/modules, with the content:

#!/bin/sh
if [ -e /sys/bus/pci/drivers/ahci ]; then
    /bin/echo 1b4b 91a2 > /sys/bus/pci/drivers/ahci/new_id 2>/dev/null
fi

but until now seems it doesn't work.

I'm all available to help fix this problem.

Comment 6 Marlos de Mendonça Corrêa 2013-01-27 02:47:16 UTC
The marvell.module archive is working. I don't know why it didn't before. Probably is because I've done a lot of things together.

With this file, all disks on Marvell controller become accessible even in raid, but I'm still not able to initialize the linux installed on that disks.

As far as I can check, grub can find the array and "testload" the kernel image with ok status.

Is there a way to tell ahci to recognize Marvell Controller through Grub?

Comment 7 Marlos de Mendonça Corrêa 2013-01-27 13:35:43 UTC
Created attachment 688434 [details]
Workaround for Marvell 88SE91xx

Comment 8 Josh Boyer 2013-09-18 20:54:52 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 9 Josh Boyer 2013-10-08 17:48:32 UTC
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Comment 10 Marlos de Mendonça Corrêa 2017-01-20 14:59:38 UTC
Created attachment 1242856 [details]
Add device id for Marvell 88se91a2

Patch created by Johannes Thumshirn <jthumshirn@suse.de>, as in https://bugzilla.opensuse.org/attachment.cgi?id=651445&action=edit

Comment 11 Marlos de Mendonça Corrêa 2017-01-20 15:03:52 UTC
Bug was reported years ago but still unsolved. 

I have attached a solution made by Johannes Thumshirn <jthumshirn@suse.de>.

Also, for more information, please see: https://bugzilla.opensuse.org/show_bug.cgi?id=950202#c3

It needs only to be commited to fedora kernel and mainstream.

Comment 12 Marlos de Mendonça Corrêa 2017-01-21 14:39:40 UTC
Fixed!


Note You need to log in before you can comment on or make changes to this bug.