Bug 735271 - iscsiadm cannot delete ipv6 discovery portal with port number specified like: [::1]:3600
Summary: iscsiadm cannot delete ipv6 discovery portal with port number specified like:...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 05:09 UTC by Gris Ge
Modified: 2012-06-26 16:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 06:15:04 UTC


Attachments (Terms of Use)

Description Gris Ge 2011-09-02 05:09:42 UTC
Description of problem:
iscsiadm cannot delete discovery portal in format of [::1]:3600
===
[root@rhel6 ~]# iscsiadm -m discovery  --portal [::1]:3600 -o delete
iscsiadm: Discovery record [::1,3600] not found!
[root@rhel6 ~]# iscsiadm -m discovery
127.0.0.1:3260 via sendtargets
::1:3260 via sendtargets
===

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.872-25.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. perform iscsi discovery against a ipv6 address.
2. Try to delete ipv6 discovery recode by this command:
    iscsiadm -m discovery  --portal [::1]:3600 -o delete

  
Actual results:
iscsiadm: Discovery record [::1,3600] not found!

Expected results:
iscsiadm remove specified discover record.

Additional info:

Comment 1 Gris Ge 2011-09-02 06:15:04 UTC
not a bug.

Need execute like this:

iscsiadm -m discovery --portal "[::1]:3260" -o delete

Comment 2 Mike Christie 2011-09-02 22:18:59 UTC
(In reply to comment #0)
> [root@rhel6 ~]# iscsiadm -m discovery
> 127.0.0.1:3260 via sendtargets
> ::1:3260 via sendtargets

> Steps to Reproduce:
> 1. perform iscsi discovery against a ipv6 address.
> 2. Try to delete ipv6 discovery recode by this command:
>     iscsiadm -m discovery  --portal [::1]:3600 -o delete

What about if you use port 3260? It looks like above we got ::1:3260, but you are using 3600.

Comment 3 Gris Ge 2011-09-05 03:22:45 UTC
[root@rhel6 ~]# iscsiadm -m discovery
::1:3260 via sendtargets
[root@rhel6 ~]# iscsiadm -m discovery -p ::1:3260 -o delete
iscsiadm: Discovery record [::1:3260,3260] not found!
[root@rhel6 ~]# iscsiadm -m discovery -p [::1]:3260 -o delete
[root@rhel6 ~]# iscsiadm -m discovery

So, just my stupid typo. Sorry for wasting your time.


Note You need to log in before you can comment on or make changes to this bug.