Bug 73529 - USB mouse usage doesn't reset idle timer
USB mouse usage doesn't reset idle timer
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-05 15:17 EDT by Dax Kelson
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 00:23:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2002-09-05 15:17:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
On Null, when on battery (haven't tried plugged in), if I only use a USB mouse, the screen blanker kicks in even though I'm actively using the USB mouse. I had my USB mouse plugged in at boot time (I wouldn't think that would make a difference as far as this bug is concerned). I'm running in runlevel 5.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to X
2. Just use the USB mouse
3. Notice the screen blanker kick in
	

Actual Results:  Screen blanks

Expected Results:  Screen doesn't blank

Additional info:

I'm also suffering from "can't restore from blanking" bug, so this is extra annoying.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=73524
Comment 1 Mike A. Harris 2002-09-07 03:55:51 EDT
It sounds to me like your clock is being screwed up when on battery.
X is _very_ clock sensitive.  If your clock goes backwards, X can
crash or hardlock.  If it goes forwards, it can prematurely trigger
the screensaver.  Where the real bug lay for your specific problem
is however is hard to say.  The only way to troubleshoot/debug something
like this is to have the machine and debug it manually.

You're probably best off reporting this to XFree86.org on the
xpert@xfree86.org mailing list, because there's a high chance that
I can't do anything about it personally, but someone there might
be able to help.

At any rate, please attach your X config file and log file, and I 
will examine them and see if I notice anything out of ordinary.
Comment 2 Mike A. Harris 2003-01-26 04:05:16 EST
My XFree86 4.2.1 packages for RHL 8.0 on ftp://people.redhat.com/mharris/testing
contain a fix for a long standing XFree86 bug which is triggered whenever
the clock goes forwards or backwards by any significant amount.

Please test the latest 4.2.1 package and indicate if it fixes the problem
or not.  Thanks.
Comment 3 Dax Kelson 2003-01-28 02:10:44 EST
I'll test this in the next couple of days and report.
Comment 4 Dax Kelson 2003-02-23 02:24:27 EST
I tested with the X server in phoebe3. Problem is still there. Whatever method
Xscreensaver uses to check idleness (it uses some X library call no?) doesn't
recognize USB mouse usage.

XFree86-4.2.99.901-20030213.0
Comment 5 Dax Kelson 2003-02-23 02:26:16 EST
I don't think this is clock related. If I use the touchpad as my mouse, there
are no problems with the screensaver kicking in while actively using it.
Comment 6 Mike A. Harris 2004-08-30 00:23:44 EDT
There haven't been any other reports of this in bugzilla since this
one, so I'm assuming this problem doesn't occur for other people.

I am able to use USB mice on all my systems with Red Hat Linux 8.0
and all newer OS releases without encountering this issue, so it
seems to be very specific to your particular hardware setup.  I'm
going to close this bug as "WORKSFORME" for now, but if you still
encounter this problem after upgrading to Fedora Core 2, and you
believe it is truly an X bug, please file a bug report in
freedesktop.org bugzilla at: http://bugs.freedesktop.org in the
"xorg" component.




Note You need to log in before you can comment on or make changes to this bug.