Bug 735313 - lldpad init scripts , stopping with nonprivileged user
Summary: lldpad init scripts , stopping with nonprivileged user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lldpad
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 735976 (view as bug list)
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-02 09:36 UTC by Petr Sklenar ⛄
Modified: 2011-12-06 14:40 UTC (History)
4 users (show)

Fixed In Version: lldpad-0.9.43-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:40:35 UTC


Attachments (Terms of Use)
Check for root privileges before any action is taken (1.01 KB, patch)
2011-09-05 12:32 UTC, Petr Šabata
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1604 normal SHIPPED_LIVE lldpad bug fix and enhancement update 2011-12-06 00:51:11 UTC

Description Petr Sklenar ⛄ 2011-09-02 09:36:27 UTC
Description of problem:
lldpad init scripts improvement

Version-Release number of selected component (if applicable):
lldpad-0.9.43-7.el6

How reproducible:
deterministic

Steps to Reproduce:
A. Insufficient rights, stopping service under nonprivileged user must fail (Expected 4, got 0)
0. petr is nonroot
1.
[petr@dell-pe-sc1435-02 ~]$ /etc/init.d/lldpad stop
[petr@dell-pe-sc1435-02 ~]$ echo $?
0
[petr@dell-pe-sc1435-02 ~]$ /etc/init.d/cups stop
[petr@dell-pe-sc1435-02 ~]$ echo $?
4


Actual results:
0

Expected results:
4

Additional info:

Comment 1 Petr Šabata 2011-09-05 12:32:40 UTC
Created attachment 521493 [details]
Check for root privileges before any action is taken

Comment 2 Petr Šabata 2011-09-05 12:33:13 UTC
Patch is ready; requesting devel_ack...

Comment 3 Petr Šabata 2011-09-07 07:13:19 UTC
*** Bug 735976 has been marked as a duplicate of this bug. ***

Comment 6 Petr Šabata 2011-09-15 11:47:57 UTC
Fixed in CVS, lldpad-0_9_43-8_el6.

Comment 9 errata-xmlrpc 2011-12-06 14:40:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1604.html


Note You need to log in before you can comment on or make changes to this bug.