Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 735317 - ngircd fails to start
Summary: ngircd fails to start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ngircd
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Andreas Thienemann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 09:54 UTC by a2471676
Modified: 2020-06-28 22:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-28 22:34:54 UTC
Type: ---


Attachments (Terms of Use)

Description a2471676 2011-09-02 09:54:40 UTC
After installation of the rpm and basic adjustments in the ngircd.conf, the ircd fails to start on CentOS5 and CentOS6.


Version-Release number of selected component (if applicable):
Tested with ngircd-17-1-el6 and ngircd-16-1-el5


Steps to Reproduce:
1. yum install ngircd
2. edit /etc/ngircd.conf
3. service ngircd start


Actual results:
[root@box ~]# service ngircd start
Starting ngircd:                                           [  OK  ]
[root@box ~]#
Message from syslogd@box at Sep  2 11:38:36 ...
 ngircd[13674]: Can't initialize Rendezvous (Howl): sw_discovery_init() failed!

Results in /var/log/messages:
Sep  2 11:38:36 box ngircd[13656]: ngircd 17-SYSLOG+ZLIB+SSL+TCPWRAP+ZEROCONF+IDENT+IRCPLUS+IPv6-i686/redhat/linux-gnu started.
Sep  2 11:38:36 box ngircd[13656]: Reading configuration from "/etc/ngircd.conf" ...
Sep  2 11:38:36 box ngircd[13656]: No SSL server key configured, SSL disabled.
Sep  2 11:38:36 box ngircd[13656]: Warning: Error during SSL initialization, continuing ...
Sep  2 11:38:36 box ngircd[13658]: Running as user ngircd(497), group ngircd(497), with PID 13658.
Sep  2 11:38:36 box ngircd[13658]: Not running with changed root directory.
Sep  2 11:38:36 box ngircd[13658]: *** WARNING *** The program 'ngircd' uses the HOWL compatibility layer of Avahi.
Sep  2 11:38:36 box ngircd[13658]: *** WARNING *** Please fix your application to use the native API of Avahi!
Sep  2 11:38:36 box ngircd[13658]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=howl&e=ngircd>
Sep  2 11:38:36 box ngircd[13658]: Can't initialize Rendezvous (Howl): sw_discovery_init() failed!
Sep  2 11:38:36 box ngircd[13658]: ngircd exiting due to fatal errors!


Expected results:
A running ngircd

Comment 1 Kevin Fenzi 2011-09-02 15:41:43 UTC
Please either: 

a) try https://admin.fedoraproject.org/updates/ngircd-18-2.el6 which should fix this issue. 

or

b) run avahi on the machine.

Comment 2 a2471676 2011-09-05 10:04:34 UTC
The updated rpm works so far.

The service starts and I can connect with an IRC client.

Thanks

Comment 3 a2471676 2011-09-06 09:30:03 UTC
Recompiled the srpm under CentOS5.
The tcp_wrapper-devel dependency had to be removed for a successful build.
So far, it seems to work, so it could be released for el5 and el6

Comment 4 Kevin Fenzi 2020-06-28 22:34:54 UTC
This was fixed a long time ago AFAICT...


Note You need to log in before you can comment on or make changes to this bug.