This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 735319 - Bluetooth Fails to Browse to Phone
Bluetooth Fails to Browse to Phone
Status: CLOSED DUPLICATE of bug 537720
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
16
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 06:01 EDT by Steven Drinnan
Modified: 2014-09-13 14:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 13:22:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven Drinnan 2011-09-02 06:01:36 EDT
Description of problem:
After upgrade to 2.6.4 I discovered that I could not browse, repaired but same result. It comes up with connection refused.

Version-Release number of selected component (if applicable):

How reproducible:
Just use 2.6.40 Kernel

Steps to Reproduce:
1. Try to browse or send files
2.
3.
  
Actual results:
Connection refused message

Expected results:
Be able to browse

Additional info:

Reverting to 2.6.38 fixes the problem.
Comment 1 Steven Drinnan 2011-09-02 06:27:09 EDT
Tried with another dongle and that works for both kernels, so it is a device specific problem. 

lsusb info

Bus 003 Device 003: ID 0db0:3801 Micro Star International 

Hope that helps

Steven
Comment 2 Nicolas Dufresne 2011-09-07 09:56:19 EDT
Same issue here, since update I can't browse neither from my Thinkpad X201, or Macbook Pro 5,5.

The MacBook runs a BCM2046 Bluetooth device.
Comment 3 Steven Drinnan 2011-09-30 04:26:23 EDT
Latest Update shows same problem
Comment 4 Juergen Schraten 2011-10-03 07:15:45 EDT
This is a really strange one:
Having the same problem from kernel 2.40* on, but only with mobiles, not with a smartphone.

I'm able to establish a new connection, but searching for files on a Nokia 3720 and a Nokia 6300 ends with:

»Error: Error invoking GnomeBluetoothApplet.browse_connection_finish: Connection refused«

But I've no problem with connecting a Nokia N8-00 smartphone: Everything works fine.
If someone needs more information,please ask.
Comment 5 Dimitris Glezos 2011-10-07 20:34:46 EDT
Confirming the same problem with Thinkpad x220 and Nokia N900.
Comment 6 Steven Drinnan 2011-10-09 06:30:17 EDT
Problem exists still in F16 beta

Please fix this error
Comment 7 Juergen Schraten 2011-10-14 09:53:11 EDT
Still doesn't work.
Further information:

> hciconfig -a hci0

hci0:	Type: BR/EDR  Bus: USB
	BD Address: 4C:ED:DE:98:92:B4  ACL MTU: 1021:8  SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN 
	RX bytes:12142 acl:72 sco:0 events:247 errors:0
	TX bytes:2745 acl:67 sco:0 commands:120 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'localhost.localdomain-0'
	Class: 0x480100
	Service Classes: Capturing, Telephony
	Device Class: Computer, Uncategorized
	HCI Version: 3.0 (0x5)  Revision: 0x274
	LMP Version: 3.0 (0x5)  Subversion: 0x4203
	Manufacturer: Broadcom Corporation (15)


Error messages still the same as mentioned above.
Comment 8 Chris 2011-10-28 04:31:07 EDT
the same here, too, trying to connect to mobile phone since july, access denied message is not gone yet

Linux host1 3.1.0-1.fc16.i686.PAE #1 SMP Mon Oct 24 12:07:34 UTC 2011 i686 i686 i386 GNU/Linux

> hciconfig -a hci0
hci0:   Type: BR/EDR  Bus: USB
        BD Address: 70:F3:95:3E:A3:C7  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING PSCAN 
        RX bytes:1066 acl:0 sco:0 events:34 errors:0
        TX bytes:887 acl:0 sco:0 commands:34 errors:0
        Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x83
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
        Link policy: RSWITCH HOLD SNIFF PARK 
        Link mode: SLAVE ACCEPT 
        Name: 'host1-0'
        Class: 0x480100
        Service Classes: Capturing, Telephony
        Device Class: Computer, Uncategorized
        HCI Version: 2.1 (0x4)  Revision: 0x168
        LMP Version: 2.1 (0x4)  Subversion: 0x4203
        Manufacturer: Broadcom Corporation (15)
Comment 9 Steven Drinnan 2011-11-18 05:09:42 EST
Done a upgrade, problem persists after update. 

Is there anyone looking into it, it seems like this is quite a problem as I see the same problem for other distros. 

Please someone just acknowledge this as a bug that needs a fix and where it should be fixed upsream or otherwise. 

Steven Drinnan
Comment 10 Steven Drinnan 2011-11-18 05:14:59 EST
As for the report that smartphone are OK, I do not believe so. I am tring to connect to an LG with Android 2.3 on it.
Comment 11 Steven Drinnan 2011-11-23 23:56:21 EST
Update: using obexftp directly works. 

I did the following

hcitool scan 'to get my address

then 

obexftp -b B0:89:91:DC:60:85 -p '/home/steven/Pictures/Halloween 2011/IMGP4199.JPG'  'to send the file

I got this 

----------------
Browsing B0:89:91:DC:60:85 ...
Connecting...failed: connect
Tried to connect for 213ms
error on connect(): Permission denied
Still trying to connect
Connecting..\done
Tried to connect for 58ms
Sending "/home/steven/Pictures/Halloween 2011/IMGP4199.JPG"...\done
----------------------------------

So as you can see the first request allways fails, but the next one succeeds. 

Steven
Comment 12 Juergen Schraten 2011-11-25 05:43:44 EST
Didn't work for me - with none of my phones.
Updated to F16, problem still exists.
May I repeat a part of my comment #4? All worked perfectly up to Kernel 2.6.39.*
What has been changed to 2.6.40?
Comment 13 Alec Leamas 2011-12-06 15:15:41 EST
See also bug 733847, which might be a dup. This one seems to be hw dependent, some dongles work, some don't.
Comment 14 Juergen Schraten 2011-12-07 09:43:36 EST
No, I don't think its dongle dependent because a) I tried three different dongles and b) I'm able to connect a smart phone, but not a cell phone. 
Yes, it is a dup, so you can close this one.
Comment 15 Chris 2012-01-13 08:11:11 EST
also in F16 with latest kernel 3.1.8-2.fc16.i686.PAE, does not work, yet:

obexftp -b xx:xx:xx:xx:xx:xx -p '/path/to/file'

Browsing xx:xx:xx:xx:xx:xx ...
Connecting...failed: connect
Tried to connect for 5ms
error on connect(): Invalid argument
Still trying to connect
Connecting...failed: connect
Tried to connect for 13ms
error on connect(): Invalid argument
Still trying to connect
Connecting...failed: connect
Tried to connect for 12ms
error on connect(): Invalid argument
Still trying to connect

hci0:   Type: BR/EDR  Bus: USB
        BD Address: 70:F3:95:3E:A3:C7  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING PSCAN ISCAN 
        RX bytes:10071 acl:292 sco:0 events:260 errors:0
        TX bytes:8189 acl:292 sco:0 commands:70 errors:0
        Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x83
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
        Link policy: RSWITCH HOLD SNIFF PARK 
        Link mode: SLAVE ACCEPT 
        Name: 'host1-0'
        Class: 0x480100
        Service Classes: Capturing, Telephony
        Device Class: Computer, Uncategorized
        HCI Version: 2.1 (0x4)  Revision: 0x168
        LMP Version: 2.1 (0x4)  Subversion: 0x4203
        Manufacturer: Broadcom Corporation (15)
Comment 16 Alec Leamas 2012-01-16 08:33:55 EST
In reply to comment #14: Well bug 733847, is certainly hw dependent, it depends on which dongle I use. So this bug is either hw dependent or not a dup.

Furthermore, I'm not in position to close this bug. I'm just a mere mortal.
Comment 17 Ricardo David 2012-11-10 16:21:19 EST
Manage to solve connecting Lenovo Z460 with Nokia N8 using Fedora 17 with Gnome Shell.

Install bluez-hid2hci, gvfs-obexftp, gnome-phone-manager. Restart bluetooth services or reboot. Clear any previous setup of the connection on phone and computer. Connect the phone with the computer, not the other way (it REALLY does not work for me). That way, all functions are up (browse, DUN, messages, etc.).
Comment 18 Martin 2012-11-22 13:22:37 EST

*** This bug has been marked as a duplicate of bug 753617 ***
Comment 19 Martin 2013-01-16 12:07:54 EST

*** This bug has been marked as a duplicate of bug 537720 ***

Note You need to log in before you can comment on or make changes to this bug.