Bug 735333 - 'yum clean' gives a wrong impression
Summary: 'yum clean' gives a wrong impression
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.2
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 11:48 UTC by Šimon Lukašík
Modified: 2014-01-21 06:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 828690 (view as bug list)
Environment:
Last Closed: 2012-06-20 13:53:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0857 normal SHIPPED_LIVE yum bug fix and enhancement update 2012-06-19 20:48:27 UTC

Description Šimon Lukašík 2011-09-02 11:48:56 UTC
Description of problem:
The command 'yum clean' is considered too ambiguous by yum to commit
any action. The error message is emitted.

However the rest of the output of Yum as whole might give a wrong
impression that the appropriate actions are made.

Version-Release number of selected component (if applicable):
yum-3.2.29-17.el6.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. Have some repositories enabled
2. yum clean
3.
  
Actual results:
# yum clean 
Loaded plugins: product-id, rhnplugin, subscription-manager
Updating Red Hat repositories.
Error: clean requires an option: headers, packages, metadata, dbcache, plugins, expire-cache, rpmdb, all
Cleaning repos: beaker rhel-x86_64-server-6
# echo $?
0

Expected results:
# yum clean 
Loaded plugins: product-id, rhnplugin, subscription-manager
Updating Red Hat repositories.
Error: clean requires an option: headers, packages, metadata, dbcache, plugins, expire-cache, rpmdb, all
# echo $?
1

Additional info:

Comment 7 errata-xmlrpc 2012-06-20 13:53:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0857.html


Note You need to log in before you can comment on or make changes to this bug.