Bug 735335 - Getting "500 Error - Internal Server Error" when trying to Clone 1500 Errata to Cloned Channel.
Summary: Getting "500 Error - Internal Server Error" when trying to Clone 1500 Errata ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 541
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2011-09-02 12:08 UTC by Dimitar Yordanov
Modified: 2015-05-29 20:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-29 20:12:30 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2011-09-02 12:08:18 UTC
Description of problem:
Getting "500 Error - Internal Server Error" when trying to Clone 1500 Errata to Cloned Channel.

Version-Release number of selected component (if applicable):
Satellite 541

How reproducible:
100%

Steps to Reproduce:
1. Channels -> Manage Software Channels -> Clone Channel
2. Clone form : Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)   
3. Clone : Original state of the channel ( no errata )
4. Selecet 1500 Errat
     1,001 - 1,500 of 2,504 (1500 selected)
5. 500 Error - Internal Server Error
6. Try to Login  again  
 
Actual results:
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Apache Server at *.redhat.com Port 443


Expected results:
No errors

Additional info:
I had to restart the Satellite in order to have it functional again.

Comment 1 Tomas Lestach 2011-09-02 14:19:20 UTC
Caused by: 
org.hibernate.PropertyValueException: not-null property references a null or tra
nsient value: com.redhat.rhn.domain.errata.impl.UnpublishedBug.summary
        at org.hibernate.engine.Nullability.checkNullability(Nullability.java:72
)

Comment 2 Dimitar Yordanov 2011-09-02 14:41:35 UTC
Step 4 in the Description is not complete. It should be:
4. Errata -> Clone Errata. Select 1500 Erratas
     1,001 - 1,500 of 2,504 (1500 selected)

Comment 3 Tomas Lestach 2011-09-02 15:25:03 UTC
To make the reproducer clear - step 4 shall contain also:
- Press "Clone Errata" and then "Confirm" button on the (clone errata) confirm page

(Just selecting of the errata isn't enough, it's necessary to clone them.)

Note: No need to select 1500 errata, selecting of just one erratum leads to the ISE as well.

Comment 4 Dimitar Yordanov 2011-09-04 20:47:27 UTC
Hi Tomas, 

 I did not face this issue with small amount of Erratas (10-20).
 I even used it as workaround.
 
Dimi

Comment 5 Tomas Lestach 2011-09-15 07:41:33 UTC
In that case, the issue you describe is different from that one I see. Please make your reproducer more accurate.

When getting an ISE, please make sure you always attach the traceback from catalina.log.


Note You need to log in before you can comment on or make changes to this bug.