Bug 73534 - please simplify httpd command line
please simplify httpd command line
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-05 16:13 EDT by Jamie Zawinski
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 16:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Zawinski 2002-09-05 16:13:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020820
apache-1.3.22-6

The "httpd" processes are launched with many -D options.  Can't you arrange for
that stuff to come from config files instead of being on the command line?

The current situation is annoying, because when I do this:

    ps auxww | grep X

I get three pages of hits, because so many words (and every capital letter!) are
present on the httpd command lines.  Not to mention that the command lines are
each ~600 characters (~8 screen lines) long.

(I don't know if this is a Red Hat issue or an Apache issue, but I can't find
any bug reporting mechanism on apache.org, so I'm reporting it here.  Please
pass it along if you deny responsibility.)
Comment 1 Joe Orton 2002-09-11 15:59:11 EDT
This is indeed a packaging issue rather than an Apache issue, and it is fixed in
the Apache 2.0 packages included in recent Red Hat Linux beta releases, where
Apache is executed simply as /usr/sbin/httpd.

The changes are rather fundamental to how we package Apache and Apache modules,
so it's not simple to back-port this to the 1.3 packages.

Note You need to log in before you can comment on or make changes to this bug.