Bug 735353 - No packages in the First Environemnt.
Summary: No packages in the First Environemnt.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Katello
Classification: Retired
Component: Webservice API
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ivan Necas
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 13:18 UTC by Bryan Kearney
Modified: 2011-09-19 07:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 07:40:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 735433 None None None Never

Description Bryan Kearney 2011-09-02 13:18:58 UTC
After promoting a product to the first environment, there are no packages in that repo on the file system.  Steps to reproduce:

- Create a new Org.
- Create a provider, and mirror a repo. 
- Sync the provider, and you see the packages in the locker
- Create a Dev Envrionment.
- Create a new change set to promote the product to Dev
- Execute the promotion.
- Look in the directories at /var/www/pub/repos/$ORG/Dev/$PRODUCT/$REPO

There are no packages there, but there is repodata.

Comment 1 Ivan Necas 2011-09-02 15:45:17 UTC
This is caused by a bug in Pulp. Filed in BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=735433

Should be fixed in next sprint.

Comment 2 Ivan Necas 2011-09-19 07:40:23 UTC
Fixed in pulp build: 0.230-2. Status of pulp BZ: verified. Closing.


Note You need to log in before you can comment on or make changes to this bug.