Bug 735367 - Test libica_3des_ecb_test present twice in TARGETS of Makefile of upstream testsuite
Summary: Test libica_3des_ecb_test present twice in TARGETS of Makefile of upstream te...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libica
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Dan Horák
QA Contact: David Kutálek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 13:39 UTC by David Kutálek
Modified: 2011-12-06 11:38 UTC (History)
1 user (show)

Fixed In Version: libica-2.1.0-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:38:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1567 normal SHIPPED_LIVE libica bug fix and enhancement update 2011-12-06 00:39:10 UTC

Description David Kutálek 2011-09-02 13:39:46 UTC
Description of problem:

Mentioned test is present twice in libica-2.1/src/tests/Makefile.linux, causing a double processing:

TARGETS = libica_des_test libica_3des_test \
          libica_aes128_test libica_aes192_test libica_aes256_test \
          libica_sha1_test \
          libica_sha256_test \
          libica_rsa_test libica_rng_test libica_keygen_test \
          test_mech_list \
          libica_cmac_test \
          libica_aes_xts_test \
          libica_aes_ctr_test libica_aes_ofb_test libica_aes_cfb_test \
          libica_aes_cbc_test libica_aes_ecb_test \
          libica_3des_ecb_test \
          libica_des_ctr_test libica_3des_ctr_test \
          libica_des_cfb_test libica_3des_cfb_test \
          libica_des_cbc_test libica_3des_cbc_test \
          libica_des_ecb_test libica_3des_ecb_test \
          libica_des_ofb_test libica_3des_ofb_test \
          libica_get_version


Version-Release number of selected component (if applicable):

libica-2.1.0-1.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 4 errata-xmlrpc 2011-12-06 11:38:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1567.html


Note You need to log in before you can comment on or make changes to this bug.