Bug 735377 - repoquery does not produce any output when querying a package
Summary: repoquery does not produce any output when querying a package
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.1
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 14:32 UTC by Jaromir Hradilek
Modified: 2014-01-21 06:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-16 19:15:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaromir Hradilek 2011-09-02 14:32:45 UTC
Description of problem:
The repoquery(1) manual page claims that the repoquery utility allows a user to display information about a package even when the package is not installed (for example, the "repoquery -l <package_name>" is supposed to produce output similar to "rpm -ql <package_name>", etc.). However, an attempt to use any of the command line options described in the "PACKAGE QUERY OPTIONS" section of the aforementioned manual page does not produce any output or error.


Version-Release number of selected component (if applicable):
yum-utils-1.1.30-6.el6.noarch
yum-rhn-plugin-0.9.1-26.el6_1.1.noarch
yum-3.2.29-17.el6.noarch


How reproducible:
Always.


Steps to Reproduce:
1. Log in as the root user:

   ~]$ su -
   Password:

2. Make sure the package you are about to query is in available
   repositories, for example:

   ~]# yum info net-snmp
   Loaded plugins: refresh-packagekit, rhnplugin
   Installed Packages
   Name        : net-snmp
   Arch        : x86_64
   ...

3. Attempt to query information about the package or list
   its content:

   ~]# repoquery -i net-snmp
   ~]# repoquery -l net-snmp
   ~]# echo $?
   0


Actual results:
The command terminates without output and returns exit code 0 (success).


Expected results:
Output similar to the one in Fedora 14, for example:

   ~]# repoquery -i net-snmp

   Name        : net-snmp
   Version     : 5.5
   Release     : 31.el6
   ...

Additional info:
The system is up-to-date and is registered with RHN Classic.

Comment 2 James Antill 2011-09-16 19:15:53 UTC
 This is due to rhn, you need to pass --plugins to get access to the RHN repos.

 RHSM should solve this.


Note You need to log in before you can comment on or make changes to this bug.