Bug 735408 - Unit loader.service entered failed state
Unit loader.service entered failed state
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squashfs-tools (Show other bugs)
16
ppc64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 11:14 EDT by Mark Hamzy
Modified: 2015-08-31 23:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-07 14:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2011-09-02 11:14:22 EDT
Description of problem:
Booting Fedora-20110902-ppc64-DVD.iso with a fixed yaboot.conf and the following options:

boot: linux serial vnc=1

I see the following:

Welcome to the 64-bit Fedora 20110902 installer!
Hit <TAB> for boot options.


Welcome to yaboot version 1.3.16 (Red Hat 1.3.16-4.fc16)
Enter "help" to get some basic usage information
boot: linux serial vnc=1 
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 04380000, size: 20164 Kbytes
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 3.0.1-5.fc16.kh.ppc64 (mockbuild@ppc-comm02) (gcc version 4.6.1 20110804 (Red Hat 4.6.1-7) (GCC) ) #1 SMP Thu Aug 11 23:47:44 UTC 2011
Max number of cores passed to firmware: 32 (NR_CPUS = 128)
Calling ibm,client-architecture-support... done
command line: ro root=live:CDLABEL=PBOOT serial vnc=1 
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 0000000005732000
  alloc_top    : 0000000010000000
  alloc_top_hi : 0000000010000000
  rmo_top      : 0000000010000000
  ram_top      : 0000000010000000
instantiating rtas at 0x000000000ee90000... done
boot cpu hw idx 0
starting cpu hw idx 4... done
starting cpu hw idx 8... done
starting cpu hw idx 12... done
starting cpu hw idx 16... done
starting cpu hw idx 20... done
starting cpu hw idx 24... done
starting cpu hw idx 28... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000005833000 -> 0x00000000058345bf
Device tree struct  0x0000000005835000 -> 0x000000000584b000
Calling quiesce...
returning from prom_init
[    0.000000] Phyp-dump disabled at boot time
[    0.000000] Using pSeries machine description
[    0.000000] Using 1TB segments
[    0.000000] Found initrd at 0xc000000004380000:0xc000000005731084
[    0.000000] bootconsole [udbg0] enabled
[    0.000000] Partition configured for 32 cpus.
[    0.000000] CPU maps initialized for 4 threads per core
[    0.000000] Starting Linux PPC64 #1 SMP Thu Aug 11 23:47:44 UTC 2011
[    0.000000] -----------------------------------------------------
[    0.000000] ppc64_pft_size                = 0x1c
[    0.000000] physicalMemorySize            = 0x410000000
[    0.000000] htab_hash_mask                = 0x1fffff
[    0.000000] -----------------------------------------------------
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.0.1-5.fc16.kh.ppc64 (mockbuild@ppc-comm02) (gcc version 4.6.1 20110804 (Red Hat 4.6.1-7) (GCC) ) #1 SMP Thu Aug 11 23:47:44 UTC 2011
[    0.000000] [boot]0012 Setup Arch
[    0.000000] EEH: No capable adapters found
[    0.000000] PPC64 nvram contains 15360 bytes
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA      0x00000000 -> 0x00410000
[    0.000000]   Normal   empty
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00280000
[    0.000000]     1: 0x00280000 -> 0x00410000
[    0.000000] [boot]0015 Setup Done
[    0.000000] PERCPU: Embedded 462 pages/cpu @c000000010000000 s1862272 r0 d30080 u2097152
[    0.000000] Built 2 zonelists in Node order, mobility grouping on.  Total pages: 4201600
[    0.000000] Policy zone: DMA
[    0.000000] Kernel command line: ro root=live:CDLABEL=PBOOT serial vnc=1 
[    0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
[    0.000000] freeing bootmem node 0
[    0.000000] freeing bootmem node 1
[    0.000000] Memory: 16671608k/17039360k available (19016k kernel code, 367752k reserved, 1696k data, 12585k bss, 8720k init)
[    0.000000] SLUB: Genslabs=15, HWalign=128, Order=0-3, MinObjects=0, CPUs=32, Nodes=256
[    0.000000] Hierarchical RCU implementation.
[    0.000000] 	RCU dyntick-idle grace-period acceleration is enabled.
[    0.000000] 	RCU lockdep checking is enabled.
[    0.000000] NR_IRQS:512 nr_irqs:512 16
[    0.000000] clocksource: timebase mult[7d0000] shift[22] registered
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [hvc0] enabled, bootconsole disabled
[    0.000000] console [hvc0] enabled, bootconsole disabled
[    0.000000] Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
[    0.000000] ... MAX_LOCKDEP_SUBCLASSES:  8
[    0.000000] ... MAX_LOCK_DEPTH:          48
[    0.000000] ... MAX_LOCKDEP_KEYS:        8191
[    0.000000] ... CLASSHASH_SIZE:          4096
[    0.000000] ... MAX_LOCKDEP_ENTRIES:     16384
[    0.000000] ... MAX_LOCKDEP_CHAINS:      32768
[    0.000000] ... CHAINHASH_SIZE:          16384
[    0.000000]  memory used by lock dependency info: 6367 kB
[    0.000000]  per task-struct memory footprint: 2688 bytes
[    0.000000] allocated 136314880 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.027613] pid_max: default: 32768 minimum: 301
[    0.028089] Security Framework initialized
[    0.028101] SELinux:  Initializing.
[    0.034379] Dentry cache hash table entries: 4194304 (order: 13, 33554432 bytes)
[    0.052145] Inode-cache hash table entries: 2097152 (order: 12, 16777216 bytes)
[    0.059641] Mount-cache hash table entries: 256
[    0.068339] Initializing cgroup subsys cpuacct
[    0.068375] Initializing cgroup subsys memory
[    0.070070] Initializing cgroup subsys devices
[    0.070079] Initializing cgroup subsys freezer
[    0.070086] Initializing cgroup subsys net_cls
[    0.070093] Initializing cgroup subsys blkio
[    0.070126] Initializing cgroup subsys perf_event
[    0.070274] ftrace: allocating 21817 entries in 129 pages
[    0.073779] POWER7 performance monitor hardware support registered
[    0.093805] Brought up 32 CPUs
[    0.094662] Enabling Asymmetric SMT scheduling
[    0.096890] devtmpfs: initialized
[    0.104816] atomic64 test passed
[    0.105206] NET: Registered protocol family 16
[    0.105283] IBM eBus Device Driver
[    0.127211] PCI: Probing PCI hardware
[    0.127227] io_event_irq: No ibm,io-events on system! IO Event interrupt disabled.
[    0.141410] bio: create slab <bio-0> at 0
[    0.142508] vgaarb: loaded
[    0.143440] SCSI subsystem initialized
[    0.144365] usbcore: registered new interface driver usbfs
[    0.144484] usbcore: registered new interface driver hub
[    0.144699] usbcore: registered new device driver usb
[    0.146140] NetLabel: Initializing
[    0.146145] NetLabel:  domain hash size = 128
[    0.146149] NetLabel:  protocols = UNLABELED CIPSOv4
[    0.146354] NetLabel:  unlabeled traffic allowed by default
[    0.234633] DMA-API: preallocated 65536 debug entries
[    0.234646] DMA-API: debugging enabled by kernel config
[    0.234686] Switching to clocksource timebase
[    0.235146] Switched to NOHz mode on CPU #17
[    0.235152] Switched to NOHz mode on CPU #22
[    0.235225] Switched to NOHz mode on CPU #27
[    0.235234] Switched to NOHz mode on CPU #12
[    0.235243] Switched to NOHz mode on CPU #24
[    0.235253] Switched to NOHz mode on CPU #29
[    0.235258] Switched to NOHz mode on CPU #7
[    0.235271] Switched to NOHz mode on CPU #2
[    0.235275] Switched to NOHz mode on CPU #0
[    0.235362] Switched to NOHz mode on CPU #4
[    0.235369] Switched to NOHz mode on CPU #19
[    0.235388] Switched to NOHz mode on CPU #14
[    0.235408] Switched to NOHz mode on CPU #9
[    0.235466] Switched to NOHz mode on CPU #1
[    0.235597] Switched to NOHz mode on CPU #21
[    0.235605] Switched to NOHz mode on CPU #16
[    0.235615] Switched to NOHz mode on CPU #31
[    0.235673] Switched to NOHz mode on CPU #26
[    0.235736] Switched to NOHz mode on CPU #11
[    0.235767] Switched to NOHz mode on CPU #6
[    0.235770] Switched to NOHz mode on CPU #13
[    0.235773] Switched to NOHz mode on CPU #28
[    0.235776] Switched to NOHz mode on CPU #23
[    0.235795] Switched to NOHz mode on CPU #3
[    0.235803] Switched to NOHz mode on CPU #18
[    0.235807] Switched to NOHz mode on CPU #8
[    0.235854] Switched to NOHz mode on CPU #20
[    0.235866] Switched to NOHz mode on CPU #30
[    0.235889] Switched to NOHz mode on CPU #25
[    0.235931] Switched to NOHz mode on CPU #5
[    0.235940] Switched to NOHz mode on CPU #15
[    0.236040] Switched to NOHz mode on CPU #10
[    0.316618] NET: Registered protocol family 2
[    0.317639] IP route cache hash table entries: 524288 (order: 10, 4194304 bytes)
[    0.322220] TCP established hash table entries: 524288 (order: 11, 8388608 bytes)
[    0.327461] TCP bind hash table entries: 65536 (order: 10, 5242880 bytes)
[    0.334231] TCP: Hash tables configured (established 524288 bind 65536)
[    0.334267] TCP reno registered
[    0.334831] UDP hash table entries: 16384 (order: 9, 3145728 bytes)
[    0.339025] UDP-Lite hash table entries: 16384 (order: 9, 3145728 bytes)
[    0.343902] NET: Registered protocol family 1
[    0.345157] Unpacking initramfs...
[    3.806537] Freeing initrd memory: 20168k freed
[    3.812406] vio 30000000: Warning: IOMMU dma not supported: mask 0xffffffffffffffff, table unavailable
[    3.827436] IOMMU table initialized, virtual merging enabled
[    3.847456] vio 4000: Warning: IOMMU dma not supported: mask 0xffffffffffffffff, table unavailable
[    3.847563] vio 4001: Warning: IOMMU dma not supported: mask 0xffffffffffffffff, table unavailable
[    3.847673] vio 4002: Warning: IOMMU dma not supported: mask 0xffffffffffffffff, table unavailable
[    3.847770] vio 4004: Warning: IOMMU dma not supported: mask 0xffffffffffffffff, table unavailable
[    3.849985] audit: initializing netlink socket (disabled)
[    3.850082] type=2000 audit(1314970380.845:1): initialized
[    3.993481] HugeTLB registered 16 MB page size, pre-allocated 0 pages
[    3.993500] HugeTLB registered 16 GB page size, pre-allocated 0 pages
[    4.015719] VFS: Disk quotas dquot_6.5.2
[    4.016082] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[    4.020030] msgmni has been set to 32603
[    4.021709] cryptomgr_test used greatest stack depth: 12048 bytes left
[    4.022529] cryptomgr_test used greatest stack depth: 12016 bytes left
[    4.022701] alg: No test for stdrng (krng)
[    4.022739] NET: Registered protocol family 38
[    4.023098] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    4.023301] io scheduler noop registered
[    4.023307] io scheduler deadline registered
[    4.023755] io scheduler cfq registered (default)
[    4.023761] start plist test
[    4.025241] end plist test
[    4.027597] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    4.027700] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[    4.030529] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    4.073679] TX39/49 Serial driver version 1.11
[    4.074761] Linux agpgart interface v0.103
[    4.080213] loop: module loaded
[    4.080817] Uniform Multi-Platform E-IDE driver
[    4.081151] ide-gd driver 1.18
[    4.082386] Fixed MDIO Bus: probed
[    4.082795] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.082986] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.083204] uhci_hcd: USB Universal Host Controller Interface driver
[    4.083716] usbcore: registered new interface driver usbserial
[    4.083833] USB Serial support registered for generic
[    4.083932] usbcore: registered new interface driver usbserial_generic
[    4.083938] usbserial: USB Serial Driver core
[    4.084342] mousedev: PS/2 mouse device common for all mice
[    4.085743] rtc-generic rtc-generic: rtc core: registered rtc-generic as rtc0
[    4.087121] device-mapper: uevent: version 1.0.3
[    4.087860] device-mapper: ioctl: 4.20.0-ioctl (2011-02-02) initialised: dm-devel@redhat.com
[    4.090499] usbcore: registered new interface driver usbhid
[    4.090506] usbhid: USB HID core driver
[    4.092527] ip_tables: (C) 2000-2006 Netfilter Core Team
[    4.092773] TCP cubic registered
[    4.092780] Initializing XFRM netlink socket
[    4.094139] NET: Registered protocol family 10
[    4.098403] Mobile IPv6
[    4.098411] NET: Registered protocol family 17
[    4.098527] Registering the dns_resolver key type
[    4.101077] registered taskstats version 1
[    4.102099] rtc-generic rtc-generic: setting system clock to 2011-09-02 13:33:01 UTC (1314970381)
[    4.102109] Initializing network drop monitor service
[    4.106678] Freeing unused kernel memory: 8720k freed
[    4.116110] mknod used greatest stack depth: 10208 bytes left
[    4.125354] mount used greatest stack depth: 8144 bytes left
[    4.269053] dracut: dracut-013-4.fc16
[    4.319190] dracut: root was live:/dev/disk/by-label/PBOOT, liveroot is now live:CDLABEL=PBOOT
[    4.363501] udevd[234]: starting version 173
[    4.455970] ibmveth 30000004: (unregistered net_device): unable to change checksum offload settings. 1 rc=0 ret_attr=2200
[    4.461139] ibmvscsi 30000002: SRP_VERSION: 16.a
[    4.461326] modprobe used greatest stack depth: 6688 bytes left
[    4.461553] scsi0 : IBM POWER Virtual SCSI Adapter 1.5.9
[    4.468681] ibmvscsi 30000002: partner initialization complete
[    4.468939] ibmvscsi 30000002: host srp version: 16.a, host partition vios (1), OS 3, max io 262144
[    4.469122] ibmvscsi 30000002: Client reserve enabled
[    4.469176] ibmvscsi 30000002: sent SRP login
[    4.469240] ibmvscsi 30000002: SRP_LOGIN succeeded
[    4.479913] ibmvscsi 30000003: SRP_VERSION: 16.a
[    4.480238] scsi1 : IBM POWER Virtual SCSI Adapter 1.5.9
[    4.482383] ibmvscsi 30000003: partner initialization complete
[    4.482470] ibmvscsi 30000003: host srp version: 16.a, host partition vios (1), OS 3, max io 262144
[    4.482583] ibmvscsi 30000003: Client reserve enabled
[    4.482607] ibmvscsi 30000003: sent SRP login
[    4.482650] ibmvscsi 30000003: SRP_LOGIN succeeded
[    4.501973] scsi 0:0:1:0: Direct-Access     AIX      VDASD            0001 PQ: 0 ANSI: 3
[    4.502748] scsi 0:0:2:0: CD-ROM            AIX      VOPTA                 PQ: 0 ANSI: 4
[    4.510716] scsi 1:0:1:0: CD-ROM            AIX      VOPTA                 PQ: 0 ANSI: 4
[    5.826073] 
[    5.826075] =============================================
[    5.826093] [ INFO: possible recursive locking detected ]
[    5.826099] 3.0.1-5.fc16.kh.ppc64 #1
[    5.826104] ---------------------------------------------
[    5.826110] udevadm/338 is trying to acquire lock:
[    5.826115]  (&mm->mmap_sem){++++++}, at: [<c000000000044580>] .drop_cop+0x70/0x13c
[    5.826133] 
[    5.826133] but task is already holding lock:
[    5.826139]  (&mm->mmap_sem){++++++}, at: [<c00000000019c6b8>] .SyS_munmap+0x40/0x70
[    5.826152] 
[    5.826153] other info that might help us debug this:
[    5.826160]  Possible unsafe locking scenario:
[    5.826161] 
[    5.826167]        CPU0
[    5.826170]        ----
[    5.826173]   lock(&mm->mmap_sem);
[    5.826178]   lock(&mm->mmap_sem);
[    5.826184] 
[    5.826185]  *** DEADLOCK ***
[    5.826186] 
[    5.826193]  May be due to missing lock nesting notation
[    5.826194] 
[    5.826200] 1 lock held by udevadm/338:
[    5.826204]  #0:  (&mm->mmap_sem){++++++}, at: [<c00000000019c6b8>] .SyS_munmap+0x40/0x70
[    5.826217] 
[    5.826217] stack backtrace:
[    5.826223] Call Trace:
[    5.826228] [c000000271757020] [c000000000015764] .show_stack+0x94/0x144 (unreliable)
[    5.826240] [c0000002717570e0] [c00000000069ff10] .dump_stack+0x24/0x2c
[    5.826250] [c000000271757160] [c0000000000ee32c] .__lock_acquire+0x176c/0x17f4
[    5.826260] [c0000002717572b0] [c0000000000ee928] .lock_acquire+0x10c/0x128
[    5.826269] [c0000002717573a0] [c000000000695dac] .down_read+0x78/0x12c
[    5.826277] [c000000271757440] [c000000000044580] .drop_cop+0x70/0x13c
[    5.826285] [c0000002717574e0] [c0000000000448d4] .destroy_context+0x2c/0x50
[    5.826295] [c000000271757570] [c0000000000a895c] .__mmdrop+0x50/0x70
[    5.826304] [c000000271757600] [c000000000096cb4] .finish_task_switch+0x10c/0x15c
[    5.826313] [c0000002717576a0] [c0000000006930fc] .schedule+0x9f8/0xaf0
[    5.826321] [c000000271757920] [c0000000000a2fb4] .__cond_resched+0x2c/0x40
[    5.826329] [c0000002717579b0] [c000000000693534] ._cond_resched+0x3c/0x48
[    5.826337] [c000000271757a30] [c0000000006952d4] .mutex_lock_nested+0x7c/0x490
[    5.826347] [c000000271757b40] [c0000000001a0f14] .anon_vma_clone+0xdc/0x170
[    5.826355] [c000000271757c10] [c00000000019b978] .__split_vma+0x108/0x278
[    5.826363] [c000000271757cd0] [c00000000019bff8] .do_munmap+0x158/0x324
[    5.826371] [c000000271757d90] [c00000000019c6cc] .SyS_munmap+0x54/0x70
[    5.826381] [c000000271757e30] [c000000000009928] syscall_exit+0x0/0x40
[    8.620306] sd 0:0:1:0: [sda] 62914560 512-byte logical blocks: (32.2 GB/30.0 GiB)
[    8.620444] sd 0:0:1:0: [sda] Write Protect is off
[    8.620450] sd 0:0:1:0: Attached scsi generic sg0 type 0
[    8.620467] sd 0:0:1:0: [sda] Mode Sense: 17 00 00 08
[    8.620610] sd 0:0:1:0: [sda] Cache data unavailable
[    8.620623] sd 0:0:1:0: [sda] Assuming drive cache: write through
[    8.621491] sr0: scsi-1 drive
[    8.621502] cdrom: Uniform CD-ROM driver Revision: 3.20
[    8.622509] sd 0:0:1:0: [sda] Cache data unavailable
[    8.622519] sd 0:0:1:0: [sda] Assuming drive cache: write through
[    8.622846] sr 0:0:2:0: Attached scsi CD-ROM sr0
[    8.623413] sr 0:0:2:0: Attached scsi generic sg1 type 5
[    8.625890] sr1: scsi-1 drive
[    8.628818] sr 1:0:1:0: Attached scsi CD-ROM sr1
[    8.629616]  sda: sda1 sda2 sda3
[    8.630175] sr 1:0:1:0: Attached scsi generic sg2 type 5
[    8.633210] sd 0:0:1:0: [sda] Cache data unavailable
[    8.633219] sd 0:0:1:0: [sda] Assuming drive cache: write through
[    8.633231] sd 0:0:1:0: [sda] Attached SCSI disk
[    8.981237] ISO 9660 Extensions: Microsoft Joliet Level 3
[    8.986160] ISO 9660 Extensions: RRIP_1991A
[    9.009035] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    9.167495] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
[    9.178559] dracut: Mounted root filesystem /dev/mapper/live-rw
[    9.674601] dracut: Switching root
[   10.149240] SELinux: 2048 avtab hash slots, 97057 rules.
[   10.245411] SELinux: 2048 avtab hash slots, 97057 rules.
[   10.297947] SELinux:  9 users, 13 roles, 3762 types, 193 bools, 1 sens, 1024 cats
[   10.297984] SELinux:  82 classes, 97057 rules
[   10.322148] SELinux:  Completing initialization.
[   10.322177] SELinux:  Setting up existing superblocks.
[   10.322200] SELinux: initialized (dev sysfs, type sysfs), uses genfs_contexts
[   10.322217] SELinux: initialized (dev rootfs, type rootfs), uses genfs_contexts
[   10.322239] SELinux: initialized (dev bdev, type bdev), uses genfs_contexts
[   10.322255] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[   10.322275] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
[   10.322299] SELinux: initialized (dev devtmpfs, type devtmpfs), uses transition SIDs
[   10.323164] SELinux: initialized (dev sockfs, type sockfs), uses task SIDs
[   10.323179] SELinux: initialized (dev debugfs, type debugfs), uses genfs_contexts
[   10.328824] SELinux: initialized (dev pipefs, type pipefs), uses task SIDs
[   10.328856] SELinux: initialized (dev anon_inodefs, type anon_inodefs), uses genfs_contexts
[   10.328869] SELinux: initialized (dev devpts, type devpts), uses transition SIDs
[   10.328900] SELinux: initialized (dev hugetlbfs, type hugetlbfs), uses transition SIDs
[   10.328917] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[   10.328933] SELinux: initialized (dev selinuxfs, type selinuxfs), uses genfs_contexts
[   10.329022] SELinux: initialized (dev sysfs, type sysfs), uses genfs_contexts
[   10.330095] SELinux: initialized (dev securityfs, type securityfs), uses genfs_contexts
[   10.330107] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
[   10.330120] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
[   10.330176] SELinux: initialized (dev sr0, type iso9660), uses genfs_contexts
[   10.330192] SELinux: initialized (dev loop0, type squashfs), not configured for labeling
[   10.330216] SELinux: initialized (dev dm-0, type ext4), uses xattr
[   10.343987] type=1403 audit(1314970387.741:2): policy loaded auid=4294967295 ses=4294967295
[   10.365479] systemd[1]: Successfully loaded SELinux policy in 370ms 724us.
[   10.412759] systemd[1]: Successfully loaded SELinux database in 46ms 839us, size on heap is 462K.
[   10.420287] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
[   10.422665] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.565803] systemd[1]: Relabelled /dev and /run in 142ms 888us.
[   10.588849] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.604161] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.614299] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.630162] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.632287] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.644132] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.654325] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.670127] SELinux: initialized (dev cgroup, type cgroup), uses genfs_contexts
[   10.670364] systemd[1]: systemd 35 running in system mode. (+PAM +LIBWRAP +AUDIT +SELINUX +SYSVINIT +LIBCRYPTSETUP; fedora)

Welcome to [1mLinux[0m!

[   10.686291] systemd[1]: Set hostname to <localhost.localdomain>.
[   10.686854] systemd[1]: Initializing machine ID from random generator.
[   10.695754] systemd[1]: /etc/mtab is not a symlink or not pointing to /proc/self/mounts. This is not supported anymore. Please make sure to replace this file by a symlink to avoid incorrect or misleading mount(8) output.
[   10.861056] systemd[1]: Failed to fully start up daemon: No such file or directory
[   10.864462] SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
[   10.871600] SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
[   10.872978] SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
[   10.874520] SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
[   10.874957] systemd[1]: Path /sys/kernel/security is already a mount point, refusing start for sys-kernel-security.automount
Started Runtime Directory.
Starting File System Check on Root Device...
Starting Apply Kernel Variables...
[   10.943684] systemd-fsck[499]: Root directory is writable, skipping check.
Starting Setup Virtual Console...
Started Load Kernel Modules.
Started Set Up Additional Binary Formats.
Starting udev Coldplug all Devices...
[   11.030126] systemd-vconsole-setup[502]: /bin/loadkeys failed with error code 1.
[   11.030449] systemd-vconsole-setup[502]: /bin/setfont failed with error code 1.
[   11.031360] systemd-vconsol used greatest stack depth: 5680 bytes left
Starting udev Kernel Device Manager...
Starting Syslog Kernel Log Buffer Bridge...
[   11.139652] udevadm used greatest stack depth: 5136 bytes left
Started Syslog Kernel Log Buffer Bridge.
Started Lock Directory.
[   11.193569] udevd[508]: starting version 173
Started File System Check on Root Device.
Started udev Kernel Device Manager.
Started Apply Kernel Variables.
Started Setup Virtual Console.
Starting Remount Root FS...
Starting STDOUT Syslog Bridge...
Started STDOUT Syslog Bridge.
Started udev Coldplug all Devices.
Starting udev Wait for Complete Device Initialization...
[   11.614529] mount[537]: warning: can't open /etc/fstab: No such file or directory
[   11.764359] EXT4-fs (dm-0): re-mounted. Opts: user_xattr,acl,barrier=1,data=ordered
Started Remount Root FS.
Starting Load Random Seed...
Starting Recreate Volatile Files and Directories...
Started Load Random Seed.
[   11.980165] systemd-tmpfiles[605]: Successfully loaded SELinux database in 21ms 338us, size on heap is 464K.
Started udev Wait for Complete Device Initialization.
Started Recreate Volatile Files and Directories.
Started anaconda performance monitor.
Starting The anaconda loader...
Starting Shell on tty2...
Started Shell on tty2.
[   12.593251] SQUASHFS error: xz_dec_run error, data probably corrupt
[   12.593269] SQUASHFS error: squashfs_read_data failed to read block 0x8042452
[   12.593280] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593288] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593319] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593326] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593356] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593363] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593393] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593400] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593429] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593436] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593487] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593494] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593524] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593531] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593560] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593568] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593598] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593605] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593634] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593641] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593670] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593677] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593706] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593713] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593745] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593752] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593781] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593788] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593830] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593837] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593877] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593885] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.593985] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.593992] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594027] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594034] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594063] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594070] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594099] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594106] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594135] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594142] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594171] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594178] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594207] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594213] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594242] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594249] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594284] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594292] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594321] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594328] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594357] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594364] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594393] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594400] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594429] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594436] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594467] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594474] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594503] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594510] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594539] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594546] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594575] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594582] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594620] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594627] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594664] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594671] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   12.594708] SQUASHFS error: Unable to read data cache entry [8042452]
[   12.594715] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235150] SQUASHFS error: xz_dec_run error, data probably corrupt
[   13.235177] SQUASHFS error: squashfs_read_data failed to read block 0x8042452
[   13.235188] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235196] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235239] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235246] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235287] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235295] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235336] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235343] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235448] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235455] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235485] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235491] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235521] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235528] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.235557] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.235564] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242542] SQUASHFS error: xz_dec_run error, data probably corrupt
[   13.242551] SQUASHFS error: squashfs_read_data failed to read block 0x8042452
[   13.242561] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242568] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242613] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242621] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242661] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242669] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242710] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242717] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242758] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242765] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242806] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242814] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242855] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242862] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242904] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242911] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.242966] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.242973] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243014] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243027] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243068] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243075] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243115] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243123] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243206] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243213] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243253] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243261] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243301] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243308] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243363] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243370] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243414] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243421] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243461] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243468] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243508] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243515] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243555] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243562] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.243741] SQUASHFS error: Unable to read data cache entry [8042452]
[   13.243748] SQUASHFS error: Unable to read page, block 8042452, size 53cc
[   13.248876] systemd[1]: loader.service: main process exited, code=killed, status=7
[   13.285869] systemd[1]: Startup finished in 4s 144ms 441us (kernel) + 6s 548ms 578us (initrd) + 2s 587ms 308us (userspace) = 13s 280ms 327us.
[   13.286013] systemd[1]: Unit loader.service entered failed state.
Comment 1 Mark Hamzy 2011-09-02 11:15:54 EDT
bash-4.2# mount /srv/pungi/test/20110902/ppc64/iso/Fedora-20110902-ppc64.iso /mnt/iso/
bash-4.2# scp /mnt/iso/LiveOS/squashfs.img root@9.5.90.169:/tmp/
bash-4.2# ssh root@9.5.90.169
-bash-4.2# mkdir /tmp/squashfs
-bash-4.2# mount /tmp/squashfs.img /tmp/squashfs/
-bash-4.2# yum install squashfs-tools
-bash-4.2# unsquashfs -dest /tmp/squashfs2 /tmp/squashfs.img
Parallel unsquashfs: Using 16 processors
1 inodes (16384 blocks) to write

[========================================================================================================-       ] 15383/16384  93%
write_xattr: failed to write xattr security.selinux for file /tmp/squashfs2/LiveOS because extended attributes are not supported by the destination filesystem

write_xattr: failed to write xattr security.selinux for file /tmp/squashfs2 because extended attributes are not supported by the destination filesystem
[============================================================================================================-   ] 15987/16384  97%
write_xattr: failed to write xattr security.selinux for file /tmp/squashfs2/LiveOS/rootfs.img because extended attributes are not supported by the destination filesystem
[===============================================================================================================\] 16384/16384 100%
created 1 files
created 2 directories
created 0 symlinks
created 0 devices
created 0 fifos
-bash-4.2# yum install e2fsprogs
-bash-4.2# e2fsck -f /tmp/squashfs2/LiveOS/rootfs.img
e2fsck 1.41.14 (22-Dec-2010)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Anaconda: 20963/131072 files (0.1% non-contiguous), 579801/2097152 blocks
-bash-4.2# mkdir /tmp/rootfs /tmp/rootfs2
-bash-4.2# mount /tmp/squashfs/LiveOS/rootfs.img /tmp/rootfs
-bash-4.2# mount /tmp/squashfs2/LiveOS/rootfs.img /tmp/rootfs2
-bash-4.2# (cd /tmp/rootfs; find . -type f | xargs sha256sum > /tmp/filelist.sha256sum)
sha256sum: ./modules/3.0.1-5.fc16.kh.ppc64/kernel/fs/btrfs/btrfs.ko: Input/output error
sha256sum: ./usr/sbin/xfs_copy: Input/output error
sha256sum: ./usr/lib64/libvpd_cxx-2.1.so.2.1.3: Input/output error
sha256sum: ./usr/lib64/libpangox-1.0.so.0.2903.0: Input/output error
sha256sum: ./usr/lib64/libnm-util.so.2.0.0: Input/output error
sha256sum: ./usr/lib64/libORBit-imodule-2.so.0.0.0: Input/output error
sha256sum: ./usr/lib64/python2.7/multiprocessing/pool.py: Input/output error
sha256sum: ./usr/lib64/python2.7/multiprocessing/dummy/__init__.py: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/_bisectmodule.so: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/_localemodule.so: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/_codecs_hk.so: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/datetime.so: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/pyexpat.so: Input/output error
sha256sum: ./usr/lib64/python2.7/lib-dynload/xxsubtype.so: Input/output error
-bash-4.2# (cd /tmp/rootfs2; find . -type f | xargs sha256sum > /tmp/filelist2.sha256sum)
-bash-4.2# gzip -c -9 /tmp/squashfs/LiveOS/rootfs.img > /tmp/rootfs.gz
gzip: /tmp/squashfs/LiveOS/rootfs.img: Input/output error
-bash-4.2# gzip -c -9 /tmp/squashfs2/LiveOS/rootfs.img > /tmp/rootfs2.gz
Comment 2 Kyle McMartin 2011-09-06 21:40:50 EDT
As a sanity check, can I get you to try extracting either the i686 or x86_64 images instead of the ppc64 one?

Thanks!
 Kyle
Comment 3 Karsten Hopp 2011-09-07 10:18:26 EDT
# file /mnt/archive/fedora/development/16/x86_64/os/isolinux/initrd.img
/mnt/archive/fedora/development/16/x86_64/os/isolinux/initrd.img: XZ compressed data
# xzcat /mnt/archive/fedora/development/16/x86_64/os/isolinux/initrd.img  > initrd
xzcat: /mnt/archive/fedora/development/16/x86_64/os/isolinux/initrd.img: Compressed data is corrupt
Comment 4 Karsten Hopp 2011-09-07 12:49:24 EDT
look like that was an invalid test, initrd.img is a concat of images. xzcat can't handle that.

What I'm currently doing to test this issue is to pack enough files into a xz compressed squashfs image, mount that via loopback and then cat each file in it to /dev/null. Some of them will fail with the I/O error mentioned above:

# mksquashfs /usr squashfs.img -comp xz -Xbjc powerpc
# mkdir mnt
# mount -o loop squashfs.img mnt
# find mnt/ -type f -print -exec cat {} >/dev/null \;

It takes a while, but then you'll get the error and squashfs errors get logged in syslog.
Comment 6 Kyle McMartin 2011-10-27 14:03:29 EDT
master@linux:.% git describe 9c1f8594df4814ebfd6822ca3c9444fb3445888d                                                                                                            (kyle@dreadnought:~/linux)
v3.1-rc6-297-g9c1f859

master@linux:.% git log v3.0.. -- lib/xz                                                                                                                                         (kyle@dreadnought:~/linux)
commit 9c1f8594df4814ebfd6822ca3c9444fb3445888d
Author: Lasse Collin <lasse.collin@tukaani.org>
Date:   Wed Sep 21 17:30:50 2011 +0300

    XZ: Fix incorrect XZ_BUF_ERROR

Yeah, it should be fixed in the 3.1 kernels in F-16 and Rawhide. Can the PowerPC people confirm and close the bug?

Thanks!
 Kyle

Note You need to log in before you can comment on or make changes to this bug.