Bug 735430 - F15 -> F16 update wipes grub2 installation / destroys GRUB2 boot loader
Summary: F15 -> F16 update wipes grub2 installation / destroys GRUB2 boot loader
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 15:36 UTC by Artem S. Tashkinov
Modified: 2011-09-07 03:40 UTC (History)
5 users (show)

Fixed In Version: grub2-1.99-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-03 19:44:37 UTC


Attachments (Terms of Use)

Description Artem S. Tashkinov 2011-09-02 15:36:42 UTC
Description of problem: I tried updating from F15 to F16, but after update grub2 died and I couldn't boot into F16.


Version-Release number of selected component (if applicable): 1.99


How reproducible: always


Steps to Reproduce:
1. Install F15 without a boot loader
2. Install grub2 as a boot loader
3. Update to F16
  
Actual results: unbootable system


Expected results: bootable system


Additional info:

This part of the %preun script is guilty - it doesn't check whether GRUB2 is already installed and active.

# XXX Ugly
rm -f /boot/%{name}/*.mod
rm -f /boot/%{name}/*.img
rm -f /boot/%{name}/*.lst
rm -f /boot/%{name}/device.map

Comment 1 Kalev Lember 2011-09-03 19:44:37 UTC

*** This bug has been marked as a duplicate of bug 735259 ***

Comment 2 Fedora Update System 2011-09-05 15:06:24 UTC
grub2-1.99-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grub2-1.99-5.fc16

Comment 3 Fedora Update System 2011-09-07 03:39:51 UTC
grub2-1.99-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.