Bug 735508 - unclean tcp shutdown over wifi
Summary: unclean tcp shutdown over wifi
Keywords:
Status: CLOSED DUPLICATE of bug 626477
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 20:38 UTC by Wolfgang Rupprecht
Modified: 2011-09-05 23:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-03 14:08:45 UTC


Attachments (Terms of Use)

Description Wolfgang Rupprecht 2011-09-02 20:38:32 UTC
Description of problem:
TCP connections are no longer shut down gracefully under fedora-15/systemd.

Version-Release number of selected component (if applicable):
systemd.x86_64                        26-9.fc15 
kernel.x86_64                     2.6.40.3-0.fc15
NetworkManager.x86_64        1:0.8.9997-6.git20110721.fc15
wpa_supplicant.x86_64                1:0.7.3-9.fc15

How reproducible:
Always

Steps to Reproduce:
1. log into a wifi system remotely via ssh
2. su -c 'shutdown -h now'
3. notice that connection just hangs.  The ssh TCP connection is never closed gracefully.
  
Actual results:
The ssh TCP just hangs.

Expected results:
The ssh TCP connection is closed gracefully before the system shuts itself down.

Additional info:
I wasn't sure which component to file the bugzilla against.  It appears that systemd is in the best position to do the right thing and to emulate the old pre-fedora-15 behavior of closing the TCP connection gracefully.   It needs to make sure that all clients with open tcp connections via the wifi interface are killed before the transport helpers (wpa_supplicant, NetworkManager) are killed.  There also needs to be enough settling time to allow the final packets to make it out the wifi interface.

Note: tcp connections via the ethernet are still closed gracefully.  The problem is only seen on wifi connections.

Comment 1 Lennart Poettering 2011-09-03 14:08:45 UTC

*** This bug has been marked as a duplicate of bug 626477 ***

Comment 2 Wolfgang Rupprecht 2011-09-03 16:59:26 UTC
It is a shame that this bug was closed because it give a bit more insight 
into how one can reliably cause the ssh hanging of bug 626477.  Are the developers testing against a hardwired ethernet system or a wifi connected system?

Closing a bug report that isn't quite the same in favor of an old one where developers state "works for me" doesn't strike me as productive.  At least try to reproduce this bug.

Comment 3 Lennart Poettering 2011-09-05 23:49:00 UTC
I'd recommend adding a comment to bug 626477 explaining that there's relevant information in this bug.


Note You need to log in before you can comment on or make changes to this bug.