Bug 735537 - Facebook plugin doesn't updates or sends messages
Facebook plugin doesn't updates or sends messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 795601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-03 05:18 EDT by Nikolai Maziashvili
Modified: 2012-03-01 04:37 EST (History)
3 users (show)

See Also:
Fixed In Version: gwibber-3.1.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 795601 (view as bug list)
Environment:
Last Closed: 2012-03-01 04:27:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nikolai Maziashvili 2011-09-03 05:18:08 EDT
Description of problem:
Facebook account is created, at least it seems that it is successfully created. But feeds doesn't get updated and messages sent do not how up.
If i press on Facebook icon to see only Fb feeds Gwibber presents me with empty list.

Version-Release number of selected component (if applicable):
Gwibber v 3.1.0, release 2.fc15

How reproducible:


Steps to Reproduce:
1. set up Fb account and try to post message.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ankur Sinha (FranciscoD) 2011-12-29 13:51:14 EST
Same here. Just set up facebook. Nothing on refresh. :/

gwibber-3.1.0-2.fc16.noarch
Comment 2 Agustin Ferrario 2012-02-20 22:17:42 EST
The problem is in the ferdora-gwibber application on facebook wich is not allowed to read the timeline. Problem is solved when lines 11 to 14 are commented from gwibber/microblog/plugins/facebook/__init__.py and the gwibber fb application is used instead.
Comment 3 Tom "spot" Callaway 2012-02-21 10:41:01 EST
I don't think Agustin is right here. I think the issue has to do with when people auth to facebook, along with a bug where the scope wasn't being properly set in the client.

I'm building a new gwibber for f15 and f16 right now that I've confirmed works for me. I would appreciate it if people having this issue could:

1) Update to gwibber-3.1.0-3.fc15 or gwibber-3.1.0-3.fc16
2) Reauthenticate to facebook. The easiest way to do this is to go into Edit->Accounts, then delete the facebook account and re-add it.

At this point, you should see the facebook posts in the gwibber main window and be able to post updates.
Comment 4 Tom "spot" Callaway 2012-02-21 10:41:21 EST
*** Bug 795601 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-02-21 10:58:56 EST
gwibber-3.1.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-3.fc16
Comment 6 Fedora Update System 2012-02-21 10:59:04 EST
gwibber-3.1.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-3.fc15
Comment 7 Agustin Ferrario 2012-02-21 12:40:19 EST
I tested your package and it works just fine. Thanks!
Comment 8 Fedora Update System 2012-02-21 20:55:22 EST
Package gwibber-3.1.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-3.1.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2133/gwibber-3.1.0-3.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-03-01 04:27:38 EST
gwibber-3.1.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-03-01 04:37:14 EST
gwibber-3.1.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.