Bug 735537 - Facebook plugin doesn't updates or sends messages
Summary: Facebook plugin doesn't updates or sends messages
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwibber
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 795601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 09:18 UTC by Nikolai Maziashvili
Modified: 2012-03-01 09:37 UTC (History)
3 users (show)

(edit)
Clone Of:
: 795601 (view as bug list)
(edit)
Last Closed: 2012-03-01 09:27:38 UTC


Attachments (Terms of Use)

Description Nikolai Maziashvili 2011-09-03 09:18:08 UTC
Description of problem:
Facebook account is created, at least it seems that it is successfully created. But feeds doesn't get updated and messages sent do not how up.
If i press on Facebook icon to see only Fb feeds Gwibber presents me with empty list.

Version-Release number of selected component (if applicable):
Gwibber v 3.1.0, release 2.fc15

How reproducible:


Steps to Reproduce:
1. set up Fb account and try to post message.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ankur Sinha (FranciscoD) 2011-12-29 18:51:14 UTC
Same here. Just set up facebook. Nothing on refresh. :/

gwibber-3.1.0-2.fc16.noarch

Comment 2 Agustin Ferrario 2012-02-21 03:17:42 UTC
The problem is in the ferdora-gwibber application on facebook wich is not allowed to read the timeline. Problem is solved when lines 11 to 14 are commented from gwibber/microblog/plugins/facebook/__init__.py and the gwibber fb application is used instead.

Comment 3 Tom "spot" Callaway 2012-02-21 15:41:01 UTC
I don't think Agustin is right here. I think the issue has to do with when people auth to facebook, along with a bug where the scope wasn't being properly set in the client.

I'm building a new gwibber for f15 and f16 right now that I've confirmed works for me. I would appreciate it if people having this issue could:

1) Update to gwibber-3.1.0-3.fc15 or gwibber-3.1.0-3.fc16
2) Reauthenticate to facebook. The easiest way to do this is to go into Edit->Accounts, then delete the facebook account and re-add it.

At this point, you should see the facebook posts in the gwibber main window and be able to post updates.

Comment 4 Tom "spot" Callaway 2012-02-21 15:41:21 UTC
*** Bug 795601 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2012-02-21 15:58:56 UTC
gwibber-3.1.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-3.fc16

Comment 6 Fedora Update System 2012-02-21 15:59:04 UTC
gwibber-3.1.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-3.fc15

Comment 7 Agustin Ferrario 2012-02-21 17:40:19 UTC
I tested your package and it works just fine. Thanks!

Comment 8 Fedora Update System 2012-02-22 01:55:22 UTC
Package gwibber-3.1.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-3.1.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2133/gwibber-3.1.0-3.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-03-01 09:27:38 UTC
gwibber-3.1.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2012-03-01 09:37:14 UTC
gwibber-3.1.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.