Bug 735538 - Aiccu is not started automatically
Summary: Aiccu is not started automatically
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: aiccu
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Conrad Meyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 09:47 UTC by Vaclav "sHINOBI" Misek
Modified: 2013-03-11 09:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-28 05:18:19 UTC


Attachments (Terms of Use)

Description Vaclav "sHINOBI" Misek 2011-09-03 09:47:27 UTC
Description of problem:
Aiccu is started before IP address is assigned through DHCP, therefore automatic start is unsuccessful.

Version-Release number of selected component (if applicable):
aiccu-2007.01.15-10.fc16.x86_64

How reproducible:


Steps to Reproduce:
1. set aiccu to be started during boot and use DHCP
2.
3.
  
Actual results:
Sep  3 09:21:21 raven aiccu: Couldn't connect to the TIC server tic.sixxs.net
Sep  3 09:21:21 raven aiccu: Couldn't retrieve first tunnel for the above reaso
n, aborting
Sep  3 09:21:21 raven systemd[1]: aiccu.service: control process exited, code=exited status=255
Sep  3 09:21:21 raven systemd[1]: Unit aiccu.service entered failed state.
Sep  3 09:21:21 raven dhclient[1178]: Internet Systems Consortium DHCP Client 4.2.2
Sep  3 09:21:21 raven dhclient[1178]: Copyright 2004-2011 Internet Systems Consortium.
Sep  3 09:21:21 raven dhclient[1178]: All rights reserved.
Sep  3 09:21:21 raven dhclient[1178]: For info, please visit https://www.isc.org/software/dhcp/
Sep  3 09:21:21 raven dhclient[1178]: 
Sep  3 09:21:22 raven NetworkManager[1063]: Internet Systems Consortium DHCP Client 4.2.2
Sep  3 09:21:22 raven NetworkManager[1063]: Copyright 2004-2011 Internet Systems Consortium.
Sep  3 09:21:22 raven NetworkManager[1063]: All rights reserved.
Sep  3 09:21:22 raven NetworkManager[1063]: For info, please visit https://www.isc.org/software/dhcp/

Expected results:


Additional info:

Comment 1 Conrad Meyer 2011-10-28 01:26:04 UTC
Apparently a dependency on network.target isn't good enough -- NetworkManager takes some time to assign an IP. I'm not sure what the best way to fix this is.

Comment 2 Conrad Meyer 2011-10-28 05:18:19 UTC
So, to address this it looks like you need to enable the wait-online service:

systemctl enable NetworkManager-wait-online.service

And that should block network.target from reporting the net is up before NM
actually has an IP. It'll slow your boot down a little bit but serialize AICCU
and NM startup correctly.

Comment 3 Pavel Šimerda (pavlix) 2013-03-11 02:58:38 UTC
(In reply to comment #2)
> So, to address this it looks like you need to enable the wait-online service:
> 
> systemctl enable NetworkManager-wait-online.service

Hi,

you can certainly use this as a workaround to the actual problem.

> And that should block network.target from reporting the net is up before NM
> actually has an IP. It'll slow your boot down a little bit but serialize
> AICCU and NM startup correctly.

Unfortunately no serialization can be viewed as a correct solution. Aiccu was always intended to connect (also) to dynamic tunnels and that is often done with dynamically changing connectivity. The only reasonable solution is cooperation between aiccu and NetworkManager.

For anyone stumbling upon this bug report, we are tracking the problem in bug #844607.


Note You need to log in before you can comment on or make changes to this bug.