Bug 735568 - SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/network_throughput.
Summary: SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /...
Keywords:
Status: CLOSED DUPLICATE of bug 735556
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9f64206a6d87e737ea9d28f4275...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 15:06 UTC by zxcv
Modified: 2011-09-05 06:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-05 06:14:55 UTC


Attachments (Terms of Use)

Description zxcv 2011-09-03 15:06:31 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/network_throughput.
time:           Sat Sep  3 12:08:02 2011

description:
:SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/network_throughput.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chfn should be allowed getattr access on the network_throughput chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chfn /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:chfn_t:s0
:Target Context                system_u:object_r:netcontrol_device_t:s0
:Target Objects                /dev/network_throughput [ chr_file ]
:Source                        chfn
:Source Path                   /usr/bin/chfn
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sat 03 Sep 2011 10:39:48 AM CLST
:Last Seen                     Sat 03 Sep 2011 10:39:52 AM CLST
:Local ID                      f2582a37-414f-4490-89e8-b116438f0dbb
:
:Raw Audit Messages
:type=AVC msg=audit(1315057192.563:1136): avc:  denied  { getattr } for  pid=2245 comm="chfn" path="/dev/network_throughput" dev=devtmpfs ino=6174 scontext=unconfined_u:unconfined_r:chfn_t:s0 tcontext=system_u:object_r:netcontrol_device_t:s0 tclass=chr_file
:
:
:Hash: chfn,chfn_t,netcontrol_device_t,chr_file,getattr
:
:audit2allow
:
:#============= chfn_t ==============
:allow chfn_t netcontrol_device_t:chr_file getattr;
:
:audit2allow -R
:
:#============= chfn_t ==============
:allow chfn_t netcontrol_device_t:chr_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-05 06:14:55 UTC

*** This bug has been marked as a duplicate of bug 735556 ***


Note You need to log in before you can comment on or make changes to this bug.