Bug 735576 - SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/btrfs-control.
Summary: SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /...
Keywords:
Status: CLOSED DUPLICATE of bug 735556
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:55975134d26502f53b087352cda...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 15:07 UTC by zxcv
Modified: 2011-09-05 06:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-05 06:20:21 UTC


Attachments (Terms of Use)

Description zxcv 2011-09-03 15:07:26 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/btrfs-control.
time:           Sat Sep  3 12:08:58 2011

description:
:SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/btrfs-control.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chfn should be allowed getattr access on the btrfs-control chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chfn /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:chfn_t:s0
:Target Context                system_u:object_r:lvm_control_t:s0
:Target Objects                /dev/btrfs-control [ chr_file ]
:Source                        chfn
:Source Path                   /usr/bin/chfn
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           util-linux-2.19.1-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sat 03 Sep 2011 10:39:48 AM CLST
:Last Seen                     Sat 03 Sep 2011 10:39:48 AM CLST
:Local ID                      32602162-f290-4395-a61e-fd9d50bb9558
:
:Raw Audit Messages
:type=AVC msg=audit(1315057188.563:106): avc:  denied  { getattr } for  pid=2245 comm="chfn" path="/dev/btrfs-control" dev=devtmpfs ino=6687 scontext=unconfined_u:unconfined_r:chfn_t:s0 tcontext=system_u:object_r:lvm_control_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1315057188.563:106): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fffd89b96d0 a1=7fffd89b4fa0 a2=7fffd89b4fa0 a3=0 items=0 ppid=2214 pid=2245 auid=1000 uid=1000 gid=1000 euid=0 suid=0 fsuid=0 egid=1000 sgid=1000 fsgid=1000 tty=pts1 ses=2 comm=chfn exe=/usr/bin/chfn subj=unconfined_u:unconfined_r:chfn_t:s0 key=(null)
:
:Hash: chfn,chfn_t,lvm_control_t,chr_file,getattr
:
:audit2allow
:
:#============= chfn_t ==============
:allow chfn_t lvm_control_t:chr_file getattr;
:
:audit2allow -R
:
:#============= chfn_t ==============
:allow chfn_t lvm_control_t:chr_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-05 06:20:21 UTC

*** This bug has been marked as a duplicate of bug 735556 ***


Note You need to log in before you can comment on or make changes to this bug.