Bug 735588 - [abrt] policycoreutils-gui-2.0.85-28.fc14: seobject.py:1933:get_all:TypeError: 'int' object is not iterable
Summary: [abrt] policycoreutils-gui-2.0.85-28.fc14: seobject.py:1933:get_all:TypeError...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:50ca1549
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 16:51 UTC by Atul Modi
Modified: 2012-07-27 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-27 13:21:58 UTC


Attachments (Terms of Use)
File: backtrace (878 bytes, text/plain)
2011-09-03 16:51 UTC, Atul Modi
no flags Details

Description Atul Modi 2011-09-03 16:51:23 UTC
abrt version: 1.1.18
architecture: i686
cmdline: /usr/bin/python -Es /usr/share/system-config-selinux/system-config-selinux.py
component: policycoreutils
executable: /usr/share/system-config-selinux/system-config-selinux.py
kernel: 2.6.35.13-92.fc14.i686
package: policycoreutils-gui-2.0.85-28.fc14
reason: seobject.py:1933:get_all:TypeError: 'int' object is not iterable
release: Fedora release 14 (Laughlin)
time: 1312183434
uid: 0

backtrace
-----
seobject.py:1933:get_all:TypeError: 'int' object is not iterable

Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 186, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 85, in __init__
    self.add_page(booleansPage.booleansPage(xml))
  File "/usr/share/system-config-selinux/booleansPage.py", line 139, in __init__
    self.load(self.filter)
  File "/usr/share/system-config-selinux/booleansPage.py", line 202, in load
    booleansList = self.booleans.get_all(self.local)
  File "/usr/lib/python2.7/site-packages/seobject.py", line 1933, in get_all
    (rc, self.blist) = semanage_bool_list(self.sh)
TypeError: 'int' object is not iterable

Local variables in innermost frame:
locallist: False
ddict: {}
self: <seobject.booleanRecords instance at 0x9aa02ac>

How to reproduce
-----
1. While updating fedora 14 automatically from GUI 
2.
3.

Comment 1 Atul Modi 2011-09-03 16:51:26 UTC
Created attachment 521333 [details]
File: backtrace

Comment 2 Miroslav Grepl 2011-09-05 11:46:50 UTC
Can you get this to happen repeatedly?

Comment 3 Daniel Walsh 2012-07-27 13:21:58 UTC
Since this version of Fedora is no longer supported I am closing this bugs.  If you are still seeing this bug in a current version of fedora, please reopen the bugzilla with the appropriate version number.


Note You need to log in before you can comment on or make changes to this bug.