Bug 735607 - MDRaidError: mddeactivate failed for /dev/md127: mdadm: stopped /dev/md127
Summary: MDRaidError: mddeactivate failed for /dev/md127: mdadm: stopped /dev/md127
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:66287eac8eb235565b865682983...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 02:45 UTC by Clyde E. Kunkel
Modified: 2012-03-26 19:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-04 03:07:14 UTC


Attachments (Terms of Use)

Description Clyde E. Kunkel 2011-09-04 02:45:57 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc3.git0.0.fc16.x86_64
product:        Fedora
reason:         MDRaidError: mddeactivate failed for /dev/md127: mdadm: stopped /dev/md127
time:           Sat Sep  3 22:41:23 2011
version:        16

description:
:The following was filed automatically by anaconda:
:anaconda 16.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/mdraid.py", line 195, in mddeactivate
:    raise MDRaidError("mddeactivate failed for %s: %s" % (device, msg))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 3022, in teardown
:    mdraid.mddeactivate(self.path)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1699, in _recursiveRemove
:    device.teardown()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1693, in _handleInconsistencies
:    self._recursiveRemove(array)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1909, in _populate
:    self._handleInconsistencies()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1797, in populate
:    self._populate(progressWindow)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 474, in reset
:    cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 116, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1203, in nextClicked
:    self.anaconda.dispatch.go_forward()
:MDRaidError: mddeactivate failed for /dev/md127: mdadm: stopped /dev/md127
:

Comment 1 Clyde E. Kunkel 2011-09-04 03:07:14 UTC
Not a bug.  Trying to work around the metadata issue by forcing select of devices and trying not to specify enough of the raid10 devices to prevent it from being considered.  Didn't work.  Have to make sure none of the raid 10 devices are specified in order to get on with an installation.


Note You need to log in before you can comment on or make changes to this bug.