Bug 735633 - Wifi fails to work after putting laptop to sleep (intel wifi wireless 1000)
Summary: Wifi fails to work after putting laptop to sleep (intel wifi wireless 1000)
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i386
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 12:02 UTC by lexual
Modified: 2012-03-15 16:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-15 16:13:38 UTC


Attachments (Terms of Use)

Description lexual 2011-09-04 12:02:32 UTC
Description of problem:
Wireless fails to work after I put laptop to sleep.
Laptop is new Lenovo Thinkpad Edge E320.


Version-Release number of selected component (if applicable):

uname -a
Linux thinkfed 2.6.40.3-0.fc15.i686 #1 SMP Tue Aug 16 04:24:09 UTC 2011 i686 i686 i386 GNU/Linux

yum list installed | kernel
kernel.i686                     2.6.40.3-0.fc15     @updates                    


How reproducible:
Just tried multiple times after rebooting and happened everytime.


Steps to Reproduce:
1. Put laptop to sleep.
2. Wake laptop from sleep.
3. Can't use wireless (option to enable wireless in network manager isn't even available [it's greyed out]).

Noticed warning in dmesg output about RF_KILL switch (see below).
This laptop doesn't have a wifi switch.
And I get this same result if I sleep by closing laptop lid, or just sleep by choosing sleep from software menu without opening/closing laptop lid.
  
Need to reboot to get wifi access again.

Actual results:

Let me know what other info is required.

Expected results:


Additional info:


lspci | grep -i wireless
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000

dmesg | grep iwl
[   17.527139] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
[   17.527143] iwlagn: Copyright(c) 2003-2011 Intel Corporation
[   17.527219] iwlagn 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   17.527232] iwlagn 0000:02:00.0: setting latency timer to 64
[   17.527263] iwlagn 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[   17.548412] iwlagn 0000:02:00.0: device EEPROM VER=0x15d, CALIB=0x6
[   17.548414] iwlagn 0000:02:00.0: Device SKU: 0X9
[   17.548416] iwlagn 0000:02:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[   17.548428] iwlagn 0000:02:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[   17.548516] iwlagn 0000:02:00.0: irq 42 for MSI/MSI-X
[   17.551509] iwlagn 0000:02:00.0: loaded firmware version 39.31.5.1 build 35138
[   18.202197] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   22.780923] NetworkManager[801]: <info> (wlan0): new 802.11 WiFi device (driver: 'iwlagn' ifindex: 3)
[  166.280423] iwlagn 0000:02:00.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[  166.280462] iwlagn 0000:02:00.0: restoring config space at offset 0x4 (was 0x4, writing 0x91600004)
[  166.280471] iwlagn 0000:02:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x10)
[  166.280483] iwlagn 0000:02:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100006)
[  166.281424] iwlagn 0000:02:00.0: RF_KILL bit toggled to disable radio.

Comment 1 lexual 2011-09-06 00:25:01 UTC
i get same bug with Debian's bug. Reported here:
https://bugzilla.kernel.org/show_bug.cgi?id=42422

Comment 2 gene smith 2011-09-07 05:33:06 UTC
I have similar problem on new HP pavilion dv7-6195us laptop with i7 sandy bridge that uses the same wireless driver iwlagn mentioned above and in Debian bug.
After awake from suspend it says "configuring" for a while then "waiting for authorization" then a pop-up occurs with my wireless key for me to confirm, which does no good (just repeats this several time before indicating connection failed). This is in gnome 3 of f15. 
In KDE of f15 I see basically the same thing but no pop-up but see a "key" symbol over the wireless icon in the tray. This cycles a few time before giving up with a notification "no connection". 
Both are fine before sleep but after wake up there seems to be no way to bring the wireless back without a full reboot.
No problem with wired connection after sleep, just wireless has the problem.
BTW, the controls in gnome3 for switching between wired and wireless seem broken (often don't respond or are greyed out for unknown reasons). KDE controls work much better once you figure out what they do (which isn't completely obvious).

Comment 3 gene smith 2011-09-11 22:43:49 UTC
(In reply to comment #1)
> i get same bug with Debian's bug. Reported here:
> https://bugzilla.kernel.org/show_bug.cgi?id=42422

I am now unable to access the kernel.org buzilla site. However, I think this bug can be fixed with a bios upgrade to the thinkpad according to this:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/812866

The bug I list below (not a thinkpad) has the same effect but is really a different bug, I think, which I will enter separately.

Comment 4 Josh Boyer 2011-10-24 19:48:33 UTC
lexual, You seem to be having issues with the F15 kernel but this bug is marked as F16.  Have you tried the BIOS update mentioned in the Ubuntu bug that Gene pointed out?  If so, have you tried an F16 kernel?

Comment 5 Stanislaw Gruszka 2012-02-26 11:32:37 UTC
We need info from lexual not jwboyer :-)


Note You need to log in before you can comment on or make changes to this bug.