Bug 735642 - [PATCH] patch to btusb.c to make 2011 macmini bluetooth work
Summary: [PATCH] patch to btusb.c to make 2011 macmini bluetooth work
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 14:16 UTC by Jurgen Kramer
Modified: 2011-09-30 08:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-30 08:38:30 UTC


Attachments (Terms of Use)
patch to enable usb bluetooth support on 2011 macmini (533 bytes, patch)
2011-09-04 14:16 UTC, Jurgen Kramer
no flags Details | Diff

Description Jurgen Kramer 2011-09-04 14:16:09 UTC
Created attachment 521373 [details]
patch to enable usb bluetooth support on 2011 macmini

Description of problem:
On the 2011 mac mini bluetooth does not work. btusb.c needs patch

Version-Release number of selected component (if applicable):
kernel-3.1.0-0.rc4.git0.0.fc16

How reproducible:
always

Steps to Reproduce:
1. Boot the latest F16 kernel
2. No BT device available
3.
  
Actual results:
No BT device available

Expected results:
BT device available

Additional info:
I've managed to create a patch to get is working.
This is not upstream as well, the latest git does not include this patch.

Comment 1 Josh Boyer 2011-09-06 14:08:05 UTC
Could you send this upstream?

Comment 2 Jurgen Kramer 2011-09-06 17:00:54 UTC
I already did:

http://www.spinics.net/lists/linux-bluetooth/msg16101.html

Now lets hope it will be picked up.

Comment 3 Jurgen Kramer 2011-09-11 11:25:55 UTC
Patch was not picked up....resend to linux-bluetooth...

Comment 4 Josh Boyer 2011-09-14 19:33:18 UTC
Looks like you're close.  Following the tips Marcel gave you should get it picked up in not too long.

Comment 5 Jurgen Kramer 2011-09-15 18:39:48 UTC
Progress! 

http://permalink.gmane.org/gmane.linux.bluez.kernel/16460

Comment 6 Jurgen Kramer 2011-09-30 08:38:30 UTC
Patch made it into 3.1rc7!
http://article.gmane.org/gmane.linux.kernel/1193980

Confirmed with kernel-3.1.0-0.rc8.git0.0.fc16.x86_64 so made it into F16.


Note You need to log in before you can comment on or make changes to this bug.