Bug 735657 - unable to handle kernel NULL pointer dereference at 00000000000000b0
Summary: unable to handle kernel NULL pointer dereference at 00000000000000b0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 16:34 UTC by Wolfgang Ulbrich
Modified: 2011-10-12 12:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 15:01:19 UTC


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2011-09-04 16:34:55 UTC
Description of problem:
starting fc16 as a linux guest in vmware workstation.
In effect i can't use hgfs shares (shared folders) in fc16.
Also the service nfs.lockd doesn't start.

If you need more info let me know.

Version-Release number of selected component (if applicable):
3.1.0-0.rc4.git0.0.fc16.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

BUG: unable to handle kernel NULL pointer dereference at 00000000000000b0
IP: [<ffffffff811560ae>] d_alloc+0x13/0x62
PGD 127e20067 PUD 12c76f067 PMD 0 
Oops: 0000 [#1] SMP 
CPU 1 
Modules linked in: vmhgfs lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack ppdev parport_pc parport vmw_balloon microcode snd_ens1371 gameport snd_rawmidi snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm vmci snd_timer e1000 snd soundcore snd_page_alloc i2c_piix4 i2c_core shpchp uinput sunrpc mptspi mptscsih mptbase scsi_transport_spi [last unloaded: scsi_wait_scan]
Pid: 888, comm: mount.vmhgfs Not tainted 3.1.0-0.rc4.git0.0.fc16.x86_64 #1 VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform
RIP: 0010:[<ffffffff811560ae>]  [<ffffffff811560ae>] d_alloc+0x13/0x62
RSP: 0018:ffff880125dd5cd8  EFLAGS: 00010246
RAX: 0000000000000001 RBX: 0000000000000000 RCX: 0000000000002066
RDX: 0000000000000000 RSI: ffff880125dd5d08 RDI: 0000000000000000
RBP: ffff880125dd5cf8 R08: 0000000000000001 R09: 00000000000002f0
R10: ffff88013fc0a000 R11: 0000000000000213 R12: ffff880125d55388
R13: ffff88013800e900 R14: ffff880125c52000 R15: 0000000000000000
FS:  00007fe4db061720(0000) GS:ffff88013fc00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00000000000000b0 CR3: 0000000128b43000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process mount.vmhgfs (pid: 888, threadinfo ffff880125dd4000, task ffff880128aec9a0)
Stack:
 0000000000000001 ffff880127d14000 ffff880125d55388 ffff88013800e900
 ffff880125dd5d18 ffffffff8115615e 0000000100002066 ffffffffa01dbb0a
 ffff880125dd5d68 ffffffffa01d8203 ffffffffa01dc4b8 ffffffff81144914
Call Trace:
 [<ffffffff8115615e>] d_alloc_name+0x61/0x63
 [<ffffffffa01d8203>] HgfsReadSuper+0x231/0x29c [vmhgfs]
 [<ffffffff81144914>] ? get_anon_bdev+0xe5/0xe5
 [<ffffffffa01d7fd2>] ? HgFsOpMount+0x1a/0x1a [vmhgfs]
 [<ffffffff81145404>] mount_nodev+0x4b/0x7e
 [<ffffffffa01d7fd0>] HgFsOpMount+0x18/0x1a [vmhgfs]
 [<ffffffff81145eb5>] mount_fs+0x69/0x158
 [<ffffffff8110eb18>] ? __alloc_percpu+0x10/0x12
 [<ffffffff8115b4a8>] vfs_kern_mount+0x63/0xa0
 [<ffffffff8115c20b>] do_kern_mount+0x4d/0xdf
 [<ffffffff8115d8aa>] do_mount+0x63c/0x69f
 [<ffffffff8115d1d2>] ? copy_mount_options+0xcb/0x12e
 [<ffffffff8115dbbb>] sys_mount+0x88/0xc2
 [<ffffffff8150b742>] system_call_fastpath+0x16/0x1b
Code: 55 48 89 e5 66 66 66 66 90 e8 a7 fc ff ff 48 85 c0 74 03 83 08 10 5d c3 55 48 89 e5 41 55 41 54 53 41 50 66 66 66 66 90 48 89 fb 
RIP  [<ffffffff811560ae>] d_alloc+0x13/0x62
 RSP <ffff880125dd5cd8>
CR2: 00000000000000b0


At least abrt doesn't except my bugzilla account in fc16, so i do it manualy

Comment 1 Josh Boyer 2011-09-06 13:05:20 UTC
Can you recreate this issue outside without using VMWare?

Comment 2 Chuck Ebbert 2011-09-12 15:01:19 UTC
This is almost certainly a bug in vmhgfs... and since vmhgfs is in the stack trace it would be impossible to recreate the bug without it.

Comment 3 Wolfgang Ulbrich 2011-10-12 12:14:51 UTC
Sorry for late answering for my regrest, because i'm working outside from my home the last month.

Chuck you're right, this bug happens only in VMware Workstion.
In a real fc16 beta installation i've no kernel bug.

In VMware Workstion 8 there is a problem to install the vmware guest addons with kernel-3.1 for the moment. The vmhgfs modul failed to build.


Note You need to log in before you can comment on or make changes to this bug.