Bug 735661 - cannot install puppet
Summary: cannot install puppet
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: puppet
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 17:00 UTC by Luke Schierer
Modified: 2011-09-04 19:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-04 19:25:44 UTC


Attachments (Terms of Use)

Description Luke Schierer 2011-09-04 17:00:23 UTC
Description of problem:
when I attempt to install puppet on a brand new rhel6.1 system, it cannot do so because it cannot find a package that meets the dependency on ruby(selinux).  

Version-Release number of selected component (if applicable): 0.25.5-1.el6


How reproducible: install a brand new system using the minimal package set.  register the system with rhn, and run yum update.  install the epel rpm for rhel6.  attempt to install puppet using yum.

Actual results:
[root@localhost ~]# yum install puppet
Loaded plugins: aliases, downloadonly, product-id, rhnplugin, subscription-manager, tmprepo
Updating Red Hat repositories.
epel/metalink                                                                                                                                                                                                 |  12 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:0.25.5-1.el6 will be installed
--> Processing Dependency: ruby(abi) = 1.8 for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby >= 1.8.1 for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: facter >= 1.5 for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-0.25.5-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-0.25.5-1.el6.noarch
--> Running transaction check
---> Package facter.noarch 0:1.6.0-2.el6 will be installed
---> Package puppet.noarch 0:0.25.5-1.el6 will be installed
--> Processing Dependency: ruby(selinux) for package: puppet-0.25.5-1.el6.noarch
---> Package ruby.x86_64 0:1.8.7.299-7.el6_1.1 will be installed
---> Package ruby-augeas.x86_64 0:0.3.0-1.el6 will be installed
--> Processing Dependency: augeas-libs >= 0.5.1 for package: ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.3.0-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.3.0-1.el6.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.299-7.el6_1.1 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.299-7.el6_1.1.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
--> Running transaction check
---> Package augeas-libs.x86_64 0:0.7.2-6.el6 will be installed
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package puppet.noarch 0:0.25.5-1.el6 will be installed
--> Processing Dependency: ruby(selinux) for package: puppet-0.25.5-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: puppet-0.25.5-1.el6.noarch (epel)
           Requires: ruby(selinux)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]# 

Expected results:
puppet installs.

Comment 1 Todd Zullinger 2011-09-04 19:25:44 UTC
EPEL requires you to enable the RHEL 'optional' channel, as noted at http://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F :

"NOTE: You need to also enable the 'optional' repository to use EPEL packages as they depend on packages in that repository."


Note You need to log in before you can comment on or make changes to this bug.