Bug 735676 - SELinux is preventing /usr/sbin/pcscd from 'getattr' accesses on the sock_file /run/pcscd.comm.
Summary: SELinux is preventing /usr/sbin/pcscd from 'getattr' accesses on the sock_fil...
Keywords:
Status: CLOSED DUPLICATE of bug 729997
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:62eade48429a87a591d180b2c41...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 21:40 UTC by zxcv
Modified: 2011-09-05 06:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-05 06:48:37 UTC


Attachments (Terms of Use)

Description zxcv 2011-09-04 21:40:30 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/pcscd from 'getattr' accesses on the sock_file /run/pcscd.comm.
time:           Sun Sep  4 18:41:38 2011

description:
:SELinux is preventing /usr/sbin/pcscd from 'getattr' accesses on the sock_file /run/pcscd.comm.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that pcscd should be allowed getattr access on the pcscd.comm sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pcscd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:pcscd_t:s0
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                /run/pcscd.comm [ sock_file ]
:Source                        pcscd
:Source Path                   /usr/sbin/pcscd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           pcsc-lite-1.7.4-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sun 04 Sep 2011 05:32:17 PM CLST
:Last Seen                     Sun 04 Sep 2011 06:39:16 PM CLST
:Local ID                      c3d54235-daa5-4bdb-afaf-5a71c99567a1
:
:Raw Audit Messages
:type=AVC msg=audit(1315172356.973:65): avc:  denied  { getattr } for  pid=2005 comm="pcscd" path="/run/pcscd.comm" dev=tmpfs ino=14345 scontext=system_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1315172356.973:65): arch=x86_64 syscall=stat success=no exit=EACCES a0=413efd a1=7fff88dd6f60 a2=7fff88dd6f60 a3=0 items=0 ppid=1 pid=2005 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pcscd exe=/usr/sbin/pcscd subj=system_u:system_r:pcscd_t:s0 key=(null)
:
:Hash: pcscd,pcscd_t,var_run_t,sock_file,getattr
:
:audit2allow
:
:#============= pcscd_t ==============
:allow pcscd_t var_run_t:sock_file getattr;
:
:audit2allow -R
:
:#============= pcscd_t ==============
:allow pcscd_t var_run_t:sock_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-05 06:48:37 UTC

*** This bug has been marked as a duplicate of bug 729997 ***


Note You need to log in before you can comment on or make changes to this bug.