Bug 735695 - subscription-manager config --remove option is not operating on multiple option requests
Summary: subscription-manager config --remove option is not operating on multiple opti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-05 02:38 UTC by John Sefler
Modified: 2011-12-06 17:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:24:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-09-05 02:38:42 UTC
Description of problem:
Many subscription-manager cli module options allow the user to specify option=value multiple times and operates on each of them, for example:
subscription-manager subscribe --pool=1 --pool=2 --pool=3
subscription-manager import --certificate=1.pem --certificate=2.pem

subscription-manager config --remove=section1.name1 --remove=section2.name2 is another case that the user may want to do, but this is not working.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.8-1.git.18.770d58e.el6.x86_64


How reproducible:


Steps to Reproduce:
# subscription-manager config --remove=rhsmcertd.proxy_port --remove=rhsmcertd.proxy_user --remove=rhsmcertd.proxy_password

  
Actual results:
You have removed the value for section rhsmcertd and name proxy_password.
The default value for proxy_password will now be used.


Expected results:
You have removed the value for section rhsmcertd and name proxy_port.
The default value for proxy_port will now be used.
You have removed the value for section rhsmcertd and name proxy_user.
The default value for proxy_user will now be used.
You have removed the value for section rhsmcertd and name proxy_password.
The default value for proxy_password will now be used.

Comment 1 Chris Duryee 2011-09-09 15:12:21 UTC
7750cc3cacc21dfebad9d7f0b4411d889f3dbfb1 master 0.96.10+

Comment 3 John Sefler 2011-09-09 16:07:07 UTC
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.9-1.git.8.4e7d06b.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager config --remove=rhsmcertd.proxy_port --remove=rhsmcertd.proxy_password --remove=server.insecure
You have removed the value for section rhsmcertd and name proxy_port.
The default value for proxy_port will now be used.
You have removed the value for section rhsmcertd and name proxy_password.
The default value for proxy_password will now be used.
You have removed the value for section server and name insecure.
The default value for insecure will now be used.


moving to VERIFIED

Comment 4 errata-xmlrpc 2011-12-06 17:24:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.