This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 735712 - (CVE-2011-2821) CVE-2011-2821 libxml2: double free caused by malformed XPath expression in XSLT
CVE-2011-2821 libxml2: double free caused by malformed XPath expression in XSLT
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
public=20110822,reported=20110822,sou...
: Security
Depends On: 710397 735715 891477 891478
Blocks: 891480
  Show dependency treegraph
 
Reported: 2011-09-05 02:52 EDT by Huzaifa S. Sidhpurwala
Modified: 2015-11-24 10:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-13 07:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2011-09-05 02:52:52 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2011-2821 to the following vulnerability.

Name: CVE-2011-2821
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2821
Reference: CONFIRM:http://code.google.com/p/chromium/issues/detail?id=89402 
Reference: CONFIRM:http://googlechromereleases.blogspot.com/2011/08/stable-channel-update_22.html 

Double free vulnerability in libxml2, as used in Google Chrome before
13.0.782.215, allows remote attackers to cause a denial of service or
possibly have unspecified other impact via a crafted XPath expression.
Comment 1 Huzaifa S. Sidhpurwala 2011-09-05 02:54:46 EDT
Upstream patch:
http://git.gnome.org/browse/libxml2/commit/?id=f5048b3e71fc30ad096970b8df6e7af073bae4cb
Comment 3 Huzaifa S. Sidhpurwala 2011-09-05 03:10:02 EDT
Created libxml2 tracking bugs for this issue

Affects: fedora-all [bug 735715]
Comment 5 errata-xmlrpc 2011-12-06 13:55:37 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2011:1749 https://rhn.redhat.com/errata/RHSA-2011-1749.html
Comment 13 Huzaifa S. Sidhpurwala 2012-01-06 06:29:55 EST
Statement:

This issue does not affect the version of libxml2 package as shipped with Red Hat Enterprise Linux 4 and 5.
Comment 16 errata-xmlrpc 2013-01-31 14:33:01 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:0217 https://rhn.redhat.com/errata/RHSA-2013-0217.html

Note You need to log in before you can comment on or make changes to this bug.