Bug 73572 - "rpm -bb" fails on RH7.3 for perl-5.8.0-51.src.rpm
Summary: "rpm -bb" fails on RH7.3 for perl-5.8.0-51.src.rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-06 06:48 UTC by Need Real Name
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 06:54:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"rpm -bb perl.spec" build log (31.39 KB, text/plain)
2002-09-06 06:54 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-09-06 06:48:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020901

Description of problem:
Build eventually fails because 'h2ph' cannot be found in build directory.

Version-Release number of selected component (if applicable):
5.8.0-51

How reproducible:
Always

Steps to Reproduce:
1. $ rpm -ivh perl-5.8.0-51.src.rpm
2. $ rpm -bb /usr/src/redhat/SPECS/perl.spec
3.
	

Actual Results:  The configure step works fine. The build step eventually fails
with the following error message:

<quote>
Can't open perl script "/var/tmp/perl-root/usr/bin/h2ph": No such file or directory
make: *** [std-headers] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.9621 (%install)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.9621 (%install)
</quote>


Expected Results:  The binary (perl-5.8.0-51.i386.rpm) package(s?) should have
been created.

Additional info:

Comment 1 Need Real Name 2002-09-06 06:54:16 UTC
Created attachment 75184 [details]
"rpm -bb perl.spec" build log

Comment 2 Chip Turner 2002-09-06 14:04:46 UTC
rpm building of Rawhide packages not supported in previous releases.  not sure
offhand what would cause what you're seeing.


Note You need to log in before you can comment on or make changes to this bug.