Bug 735721 - Extremely slow network with Intel "Ultimate N WiFi Link 5300" (iwlagn) after upgrade from Fedora 14
Extremely slow network with Intel "Ultimate N WiFi Link 5300" (iwlagn) after...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On: 708747 804259
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-05 03:43 EDT by Stanislaw Gruszka
Modified: 2012-06-07 03:16 EDT (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 708747
Environment:
Last Closed: 2012-06-07 03:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of wireless configuration (173.91 KB, image/png)
2011-11-06 10:53 EST, Håvard Wigtil
no flags Details
Kernel log of some more thorough testing (115.01 KB, text/plain)
2011-11-17 17:58 EST, Felix Kaechele
no flags Details

  None (edit)
Description Stanislaw Gruszka 2011-09-05 03:43:13 EDT
+++ This bug was initially created as a clone of Bug #708747 +++

Description of problem:
After upgrading from Fedora 14, wireless network is so slow that it's literally unusable. Even simple web pages time out before they can load, can't check mail, etc. Wired networking on upgraded machine works as normal, as do the wireless network from other devices.

Version-Release number of selected component (if applicable):
kernel-2.6.38.6-27.fc15.x86_64

How reproducible: always


Steps to Reproduce:
1. Connect to wireless network
2. Access any network-based service
  
Actual results:
Timeouts or extremely slow responses


Expected results:
Internet!

Additional info:
I'd be happy to provide any extra information you may need. I'm connecting to a D-Link DAP-1522.

Output from lspci:
03:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
	Subsystem: Intel Corporation Device 1011
	Physical Slot: 1
	Flags: bus master, fast devsel, latency 0, IRQ 49
	Memory at f4300000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-16-ea-ff-ff-e5-76-72
	Kernel driver in use: iwlagn
	Kernel modules: iwlagn

Output from iwconfig:
wlan0     IEEE 802.11abgn  ESSID:"<masked>"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: <masked>   
          Bit Rate=58.5 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:254  Invalid misc:35   Missed beacon:0


--- Additional comment from havardw@pvv.org on 2011-09-04 17:31:32 EDT ---

I've tested kernel-2.6.40.4-5.fc15.x86_64, and the issue as *originally* *reported* persists. The "router kill" problems that first appeared in comment #8 is most likely another issue, as I never had any problems with the wireless router, and it still works for other devices at the same time that I see these problems in Fedora 15.
Comment 1 Stanislaw Gruszka 2011-09-05 03:45:34 EDT
This is also upstream issue as pointed in
https://bugzilla.redhat.com/show_bug.cgi?id=708747#c6
Workaround: use 11n_disable=1
Comment 2 Don Fry 2011-09-06 13:12:02 EDT
Does the D-link have loadable firmware?  Is this a stock unmodified AP?  I am trying to obtain one to debug this issue and want to obtain the proper hardware.
Comment 3 Håvard Wigtil 2011-09-06 17:51:18 EDT
The AP is not modified in any way, and running firmware "1.11 , 14:47:43 10/27/2008".
Comment 4 Don Fry 2011-09-13 14:01:16 EDT
I now have a D-link DAP-1522.  The firmware that came with it is 1.40 15:33:06 01/14/2011.  How do you have the AP configured?  bridge/auto/ap?  what band 2.4/5.2?  any encryption or open?  none/WEP/WPA ?  Anything else you can tell me to help me reproduce and fix this?  Thanks.
Comment 5 Stanislaw Gruszka 2011-09-14 05:47:35 EDT
Hmm, I'm a bit afraid that could be AP problem, firmware 1.11 from 2008 is pretty old. Håvard did you tried to update AP firmware?
Comment 6 Håvard Wigtil 2011-09-21 14:10:55 EDT
I've tried to update the firmware to the latest version available on the Norwegian Dlink site, which is 1.21 (dated 12/11/2009, see http://www.dlink.no/cs/Satellite?c=Product_C&childpagename=DLinkEurope-NO%2FDLTechProduct&cid=1197378063653&p=1197318956615&packedargs=QuickLinksParentID%3D1197318956615%26locale%3D1195806934998&pagename=DLinkEurope-NO%2FDLWrapper).

The problem persists on Fedora 15, still works with Fedora 14 with 2.6.35.something kernel on the same hardware.
Comment 7 Don Fry 2011-10-27 15:23:51 EDT
Sorry, I missed seeing your last reply until now.  How do you have the AP configured?  See my questions in #4
Comment 8 Håvard Wigtil 2011-11-06 10:53:10 EST
Created attachment 531936 [details]
Screenshot of wireless configuration

I've attached a screenshot that shows the configuration screen (with SSID and WPA pass phrase erased).
Comment 9 Don Fry 2011-11-11 12:10:38 EST
Thank you.  I will work on reproducing this problem with your configuration.
Comment 10 Felix Kaechele 2011-11-12 15:26:29 EST
I think my setup is affected by this bug as well. I'm too using a Intel Corporation Ultimate N WiFi Link 5300 in a ThinkPad X200 connecting to a D-Link DIR-825 Rev. B1. The D-Link is running OpenWRT trunk r28993 compiled about an hour ago. The driver used for the two D-Link radios is ath9k.
More information about the hardware can be obtained at http://wiki.openwrt.org/toh/d-link/dir-825

I get very high Tx excessive retries and Invalid misc values when running the Intel WiFi in n mode.

I think this mostly is an interop problem between Intel WiFi cards and other 802.11n equipment as I have never managed to get a stable 802.11n connection using my Intel WiFi. My Linksys AE1000 USB adapter (which is based on a Ralink RT3572 chipset) does not show these symptoms when used on the same machine with the same AP.

The uCode version used on my machine is 8.83.5.1 build 33692
Comment 11 Felix Kaechele 2011-11-17 15:54:35 EST
The latest iwlwifi from compat-wireless-2011-11-16 actually gives me pretty decent performance. So far my connection didn't stall and I am able to transfer files with roughly 6 MB/s.
However the number of TX failed packages seems quite high and is increasing all the time:
[felix@delta ~]$ iw wlan0 station dump
Station 00:24:01:6b:98:2a (on wlan0)
	inactive time:	0 ms
	rx bytes:	2641172222
	rx packets:	1736948
	tx bytes:	62959120
	tx packets:	570040
	tx retries:	16339
	tx failed:	345529
	signal:  	-50 dBm
	signal avg:	-50 dBm
	tx bitrate:	150.0 MBit/s MCS 7 40Mhz short GI
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:		no
(The data above is after transferring about 2,5GB, it seems to be stuck on 150 Mb/s due to the secondary channel being deactivated because I've been doing some testing on the same Band)
Comment 12 Felix Kaechele 2011-11-17 17:58:23 EST
Created attachment 534326 [details]
Kernel log of some more thorough testing

So after some more thorough testing I for now conclude that 802.11n on my 5300 ist still pretty unusable. After being away from my computer for about an hour or so, leaving it sit idle, I came back and my network connection was still established but no data was flowing. In the meantime it seems that the machine was reconnecting the to the AP often and the kernel oopsed three times (all regarding iwlwifi).
I have attached my dmesg. I redacted the part where NetworkManager decided to spam the kernel log for parsing all the networks I have configured.
Comment 13 Jason Ekstrand 2011-11-22 15:42:55 EST
I recently switched from Debian 6.0 to Fedora 16 and am having this problem as well.

Computer:
Lenovo x201x
Centrino Advanced-N6200

Router:
Buffalo WZR-HP-G300NH
DD-WRT build 16783.

I'm seeing the high transmit failure as in comment 11. I switched my router to run in BG mode and everything seems fine.

One other note, There is an access point at school that I connect to frequently that I think is Wireless-N and I haven't noticed any trouble with it. We're on break right now, but I'll do more testing with it when I get back. It's administered by the school, so unfortunately, I may not be able to provide any specs.
Comment 14 Alex Lancaster 2011-11-23 18:22:24 EST
I have the same problem with f16 with the following card (using iwlagn):

"Intel Centrino Advanced-N + WiMax 6250 (rev5f) "

Disabling "n" mode does fix it.  I opened up an "Ask Fedora" question on this:

http://ask.fedoraproject.org/question/439/workarounds-for-very-slow-wifi-using-iwlagn-driver
Comment 15 Alex Lancaster 2011-11-23 18:28:29 EST
I'm on kernel-3.1.1-2.fc16.x86_64
Comment 16 Stanislaw Gruszka 2012-01-31 03:20:22 EST
Note this issue is a regression caused by updating kernel from 2.6.35 to 2.6.38, if your iwl ifi device works well on 2.6.38 and stop working on some other kernel version, you are hitting different problem, and need to open a separate bug for it.
Comment 17 Josh Boyer 2012-06-06 15:16:20 EDT
Stanislaw, F15 is going EOL in less than a month.  What do you want to do with this bug?
Comment 18 João Gomes 2012-06-06 15:58:49 EDT
I'm having the same problem but in Fedora 17 with the Centrino Advanced N 6230.
I don't known if this happened also with the previous Fedora versions as this is a new laptop.
I'm using the iwlwifi-6000g2b-6.ucode firmare.

I tried the using only the g mode in the router, but the problem remains.
I thought that maybe I was too far from the AP, but I don't have the same problem when I use Windows in the same laptop and, in this case, even the connection speed is better.
Comment 19 Alex Lancaster 2012-06-06 20:33:27 EDT
I can demonstrate the bug in f16 with this hardware, so upgrading to that.  Feel free to bump to f17 if you can reproduce it there.
Comment 20 Stanislaw Gruszka 2012-06-07 03:16:39 EDT
I can not fix that issues. Feel free test on latest kernel/compat-wireless and fill bug report on http://bugzilla.intellinuxwireless.org/ .

Note You need to log in before you can comment on or make changes to this bug.