Bug 735743 - texlive-pdftex-bin (from TeXlive 2011) dependency problem
Summary: texlive-pdftex-bin (from TeXlive 2011) dependency problem
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 09:22 UTC by Christian Jann
Modified: 2013-07-02 23:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-01 15:26:03 UTC


Attachments (Terms of Use)

Description Christian Jann 2011-09-05 09:22:11 UTC
Description of problem:

dependency problem

Version-Release number of selected component (if applicable):

texlive-pdftex-bin-2011-1.20110825.svn23498.fc15.x86_64 (texlive)

Steps to Reproduce:

TeX Live 2011 development for Fedora 15/rawhide:
sudo rpm -i http://jnovy.fedorapeople.org/texlive/packages.f15/texlive-release.noarch.rpm
sudo yum install texlive

--> Running transaction check
---> Package texlive-pdftex-bin.x86_64 0:2011-1.20110825.svn23498.fc15 will be installed
--> Processing Dependency: libpoppler.so.13()(64bit) for package: texlive-pdftex-bin-2011-1.20110825.svn23498.fc15.x86_64
---> Package texlive-pst-math.noarch 0:2011-0.2.0.61.svn20176.fc15 will be installed
--> Finished Dependency Resolution
Error: Package: texlive-pdftex-bin-2011-1.20110825.svn23498.fc15.x86_64 (texlive)
           Requires: libpoppler.so.13()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Christian Jann 2011-10-01 15:26:03 UTC
I've overseen that there is a packages.f16 folder on the server because in the wiki is written Fedora 15/rawhide and now after changing it from packages.f15/texlive-release.noarch.rpm to packages.f16/texlive-release.noarch.rpm installing texlive works. I've also updated the wiki entry at https://fedoraproject.org/wiki/Features/TeXLive.

Comment 2 Máté Wierdl 2012-03-08 02:28:23 UTC
This is still a problem: I just did, today


# rpm -i http://jnovy.fedorapeople.org/texlive/2011/packages.fc16/texlive-release.noarch.rpm


Then, when I type 

yum install texlive

I still get the error

texlive-pdftex-bin-2011-5.20120115_r25109.svn23498.fc15.x86_64 (texlive)
          Megkövetel: libpoppler.so.13()(64bit)

(Megkövetel= requires)

In other words, the fc16 texlive install still installs the fc15 version of pdftex.

Comment 3 Máté Wierdl 2012-03-08 02:47:12 UTC
Never mind: I didn't do the 'yum clean all' step before installing texlive for fc16.


Note You need to log in before you can comment on or make changes to this bug.